Bug 1415456

Summary: Sagemath package broken/cannot be installed due to broken Singular & polymake pacakge dependencies
Product: [Fedora] Fedora Reporter: Paul DeStefano <paul.destefano-redhat2>
Component: sagemathAssignee: Paulo Andrade <paulo.cesar.pereira.de.andrade>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 25CC: brad, lantw44, paulo.cesar.pereira.de.andrade, redhat
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: sagemath-7.5.1-1.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-04-20 12:01:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul DeStefano 2017-01-22 07:54:17 UTC
Description of problem:
After system upgrade, conflict with git, perl, vim failed additional updates until I uninstalled sagemath completely--at least that's the first solution that worked after consulting other bugs.

Now, after resolving those other conflicts, I cannot install sagemath since no Singular exists to satisfy depends and Sigular cannot be installed because no libpolymake exists satisfying depends (perl, but it looks like that does exist to me.)

Version-Release number of selected component (if applicable):


How reproducible:
Always since upgrade today, F25.

Steps to Reproduce:
1. dnf install sagemath
2.
3.

Actual results:
Error: package sagemath-7.3-7.fc25.x86_64 requires Singular, but none of the providers can be installed

P.S.  I use this for work and I'm a bit worried now.  Happy to help troubleshoot, test pkgs, whatever, just need instructions.

Comment 1 Brad Ackerman 2017-01-22 18:39:18 UTC
There's a workaround available, at least - sagemath.org provides binaries you can download.

Possibly blocked by #1181772

Comment 2 Paul DeStefano 2017-01-22 18:49:42 UTC
Thanks!  Good suggestion.  Was going to check flatpak, but that was wishful thinking.  I didn't know they had binaries.  I could compile, too, it's just sometimes that's trouble; that's why I use Fedora.

Moreover, thanks for the reference and details.  Now I know not to count on a quick fix or a repackage.  That helps my calculus quit a bit.

Comment 3 Fedora Update System 2017-04-16 23:21:36 UTC
Macaulay2-1.9.2-1.fc26, Singular-4.1.0p2-1.fc26, arb-2.10.0-1.fc26, cbmc-5.7-1.fc26, coin-or-Cbc-2.9.8-3.fc26, coin-or-Osi-0.107.8-3.fc26, coin-or-SYMPHONY-5.6.14-3.fc26, coin-or-lemon-1.3.1-10.fc26, eclib-20170330-1.fc26, fflas-ffpack-2.2.2-5.fc26, flint-2.5.2-15.fc26, frobby-0.9.0-10.fc26, gap-pkg-float-0.7.5-2.fc26, giac-1.2.3-3.25.fc26, givaro-4.0.2-5.fc26, glpk-4.61-1.fc26, latte-integrale-1.7.3b-3.fc26, libfplll-5.0.3-1.fc26, libgap-4.8.6-1.fc26, linbox-1.4.2-7.fc26, normaliz-3.1.4-1.fc26, ntl-10.3.0-1.fc26, octave-4.2.1-2.fc26, openms-2.1.0-7.20170131gitbde813.fc26, polymake-3.1-2.fc26, pynac-0.7.3-1.fc26, python-cvxopt-1.1.9-4.fc26, sagemath-7.5.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e8cf20cbb

Comment 4 Fedora Update System 2017-04-20 12:01:16 UTC
Macaulay2-1.9.2-1.fc26, Singular-4.1.0p2-1.fc26, arb-2.10.0-1.fc26, cbmc-5.7-1.fc26, coin-or-Cbc-2.9.8-3.fc26, coin-or-Osi-0.107.8-3.fc26, coin-or-SYMPHONY-5.6.14-3.fc26, coin-or-lemon-1.3.1-10.fc26, eclib-20170330-1.fc26, fflas-ffpack-2.2.2-5.fc26, flint-2.5.2-15.fc26, frobby-0.9.0-10.fc26, gap-pkg-float-0.7.5-2.fc26, giac-1.2.3-3.25.fc26, givaro-4.0.2-5.fc26, glpk-4.61-1.fc26, latte-integrale-1.7.3b-3.fc26, libfplll-5.0.3-1.fc26, libgap-4.8.6-1.fc26, linbox-1.4.2-7.fc26, normaliz-3.1.4-1.fc26, ntl-10.3.0-1.fc26, octave-4.2.1-2.fc26, openms-2.1.0-7.20170131gitbde813.fc26, polymake-3.1-2.fc26, pynac-0.7.3-1.fc26, python-cvxopt-1.1.9-4.fc26, sagemath-7.5.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.