Bug 1415529

Summary: rawtherapee-5.0 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: rawtherapeeAssignee: Mattia Verga <mattia.verga>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mattdm, mattia.verga, sebastian, thibault.north
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-23 18:49:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
none
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. none

Description Upstream Release Monitoring 2017-01-23 00:21:13 UTC
Latest upstream release: 5.0-gtk3
Current version/release in rawhide: 4.2.1234-2.20161105gitb766110.fc26
URL: http://rawtherapee.com/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4165/

Comment 1 Upstream Release Monitoring 2017-01-23 00:22:01 UTC
Patching or scratch build for rawtherapee-4.2.1234 failed.

Comment 2 Upstream Release Monitoring 2017-01-23 00:22:03 UTC
Created attachment 1243491 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.

Comment 3 Upstream Release Monitoring 2017-01-23 00:22:05 UTC
Patches were not touched. All were applied properly

Comment 4 Upstream Release Monitoring 2017-01-23 18:09:19 UTC
Latest upstream release: 5.0
Current version/release in rawhide: 4.2.1234-2.20161105gitb766110.fc26
URL: http://rawtherapee.com/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4165/

Comment 5 Upstream Release Monitoring 2017-01-23 18:10:11 UTC
Patching or scratch build for rawtherapee-4.2.1234 failed.

Comment 6 Upstream Release Monitoring 2017-01-23 18:10:14 UTC
Created attachment 1243745 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.

Comment 7 Upstream Release Monitoring 2017-01-23 18:10:16 UTC
Patches were not touched. All were applied properly

Comment 8 Matthew Miller 2017-01-23 18:58:24 UTC
From http://rawtherapee.com/blog/rawtherapee-5-released, there are a few things to be aware of.... 

* There are known bugs using GTK+ versions 3.20-3.22 where scrollbars may appear stuck (issue #3545), and where the Retinex tool's "Gain and Offset" panel may appear under the "Transmission" panel until the user hovers the mouse cursor over a curve button (issue #3525). For this reason we recommend using GTK+ 3.16-3.18 if possible.

https://github.com/Beep6581/RawTherapee/issues/3545
https://github.com/Beep6581/RawTherapee/issues/3525

* Use -DCMAKE_CXX_FLAGS="-std=c++11"


Without bundling gtk3-3.16 (no, please)... let's hope there's a fix before F26 release.

The second isn't part of the standard optflags, but is something we can add, right?

Comment 9 Mattia Verga 2017-01-24 06:43:22 UTC
(In reply to Matthew Miller from comment #8)

> 
> Without bundling gtk3-3.16 (no, please)... let's hope there's a fix before
> F26 release.
> 
I've build it on Rawhide and F25, but still not released in updates-testing. I've downloaded and installed the rpm from koji, and it doesn't seem to have big problems.

> The second isn't part of the standard optflags, but is something we can add,
> right?
In the build available I did not set it, but I tried to modify the settings in the spec file with -DCMAKE_CXX_FLAGS="$RPM_OPT_FLAGS -std=c++11", but with that it still builds with "-std=c++11 -std=gnu++11"... and the latter wins (I think). I need to figure out how to change it (if it is really required... the available build created with -std=gnu++11 is working well on my system, can you test it?).

Comment 10 Mattia Verga 2017-01-24 09:46:49 UTC
Well, I've asked help on devel mailing list and a user pointed me to the fact that RawTherapee sources set gnu++11 as compiler:
https://github.com/Beep6581/RawTherapee/blob/master/CMakeLists.txt#L23

I will ask upstream why they recommend to use c++11 if the sources set it gnu++11...

Comment 11 Matthew Miller 2017-01-24 16:48:12 UTC
Looks like the c++11 thing is fine, from devel list conversation.

Do you see the scrollbar and curves refresh issues mentioned in those upstream bugs?

Comment 12 Mattia Verga 2017-01-24 18:16:08 UTC
(In reply to Matthew Miller from comment #11)
> Looks like the c++11 thing is fine, from devel list conversation.
> 
> Do you see the scrollbar and curves refresh issues mentioned in those
> upstream bugs?

I don't see any problem with scrollbars; I can see the problem with curves, but it doesn't seem to me that causes a loss of functionality.

I've pushed the build in f25-updates-testing if you want to try it.