Bug 1415645

Summary: Neutron is out of sync with version requirements
Product: Red Hat OpenStack Reporter: Yurii Prokulevych <yprokule>
Component: openstack-neutronAssignee: Jakub Libosvar <jlibosva>
Status: CLOSED ERRATA QA Contact: Eran Kuris <ekuris>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 11.0 (Ocata)CC: amuller, chrisw, dsavinea, jlibosva, mcornea, nyechiel, oblaut, ragiman, sasha, slinaber, srevivo
Target Milestone: rcKeywords: AutomationBlocker, Triaged
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-neutron-10.0.0-0.20170217121913.7f7daec.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 19:41:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Yurii Prokulevych 2017-01-23 10:37:25 UTC
Description of problem:
-----------------------

RHOS-11 setup. Failed to spawn a vm. Traceback in neutron/openvswitch-agent.log:
--------------------------------------------------------------------------------
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager [-] ofctl_service: Exception occurred during handler processing. Backtrace from offending handler [_handle_send_msg] servicing event [SendMsgRequest] fol
lows.
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager Traceback (most recent call last):
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/base/app_manager.py", line 290, in _event_loop
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     handler(ev)
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/app/ofctl/service.py", line 139, in _handle_send_msg
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     datapath.send_msg(msg)
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/controller/controller.py", line 335, in send_msg
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     msg.serialize()
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/ofproto/ofproto_parser.py", line 211, in serialize
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     self._serialize_body()
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/ofproto/ofproto_v1_3_parser.py", line 2658, in _serialize_body
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     inst.serialize(self.buf, offset)
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/ofproto/ofproto_v1_3_parser.py", line 2822, in serialize
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     a.serialize(buf, action_offset)
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/ofproto/nx_actions.py", line 381, in serialize
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     data += spec.serialize()
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/ofproto/nx_actions.py", line 96, in serialize
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     buf += self._serialize_subfield(self.src)
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/ofproto/nx_actions.py", line 122, in _serialize_subfield
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     n = ofp.oxm_from_user_header(field)
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/ofproto/oxx_fields.py", line 58, in _from_user_header
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     (num, t) = _get_field_info_by_name(oxx, name_to_field, name)
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager   File "/usr/lib/python2.7/site-packages/ryu/ofproto/oxx_fields.py", line 53, in _get_field_info_by_name
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager     raise KeyError('unknown %s field: %s' % (oxx.upper(), name))
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager KeyError: 'unknown OXM field: vlan_tci'
2017-01-23 09:16:19.796 164100 ERROR ryu.base.app_manager 



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
puppet-neutron-10.1.0-0.20170116114810.27f2987.el7ost.noarch
python-neutron-10.0.0-0.20170117115313.ada4237.1.el7ost.noarch
openstack-neutron-metering-agent-10.0.0-0.20170117115313.ada4237.1.el7ost.noarch
openstack-neutron-lbaas-10.0.0-0.20170112234530.a527cfe.el7ost.noarch
python-neutronclient-6.0.0-0.20161205101534.f53d624.el7ost.noarch
openstack-neutron-10.0.0-0.20170117115313.ada4237.1.el7ost.noarch
openstack-neutron-sriov-nic-agent-10.0.0-0.20170117115313.ada4237.1.el7ost.noarch
openstack-neutron-common-10.0.0-0.20170117115313.ada4237.1.el7ost.noarch
python-neutron-lbaas-10.0.0-0.20170112234530.a527cfe.el7ost.noarch
openstack-neutron-ml2-10.0.0-0.20170117115313.ada4237.1.el7ost.noarch
python-neutron-lib-1.0.0-0.20161108104854.efd7a3a.el7ost.noarch
openstack-neutron-openvswitch-10.0.0-0.20170117115313.ada4237.1.el7ost.noarch

Steps to Reproduce:
-------------------
1. Deploy RHOS-11 overcloud:

openstack overcloud deploy --templates \
-r /usr/share/openstack-tripleo-heat-templates/roles_data.yaml \
--ntp-server clock1.rdu2.redhat.com \
-e ${THT}/environments/network-isolation.yaml \
-e ${THT}/environments/storage-environment.yaml \
-e ${THT}/environments/tls-endpoints-public-ip.yaml \
-e /home/stack/enable-panko.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml \
-e ~/yprokule_notes/ComposableTelemetryRole/telemetry-nodes.yaml \
-e ~/yprokule_notes/ComposableTelemetryRole/network/network-environment-v4.yaml \ 
-e ~/yprokule_notes/ComposableTelemetryRole/ceph-disk-layout.yaml \
-e ~/yprokule_notes/ComposableTelemetryRole/public_vip_v4.yaml \
-e ~/yprokule_notes/ComposableTelemetryRole/enable-tls.yaml \
-e ~/yprokule_notes/ComposableTelemetryRole/inject-trust-anchor.yaml \
-e ~/yprokule_notes/ComposableTelemetryRole/neutron_config.yaml

2. Content of neutron_config.yaml:
cat ~/yprokule_notes/ComposableTelemetryRole/neutron_config.yaml
parameter_defaults:
  NeutronExternalNetworkBridge: "''"
  NeutronBridgeMappings: 'datacentre:br-ex,tenant:br-isolated'
  NeutronEnableIsolatedMetadata: 'True'
  NeutronNetworkType: 'vxlan,gre,vlan,flat'
  NeutronTunnelTypes: 'vxlan,gre'
  NeutronNetworkVLANRanges: 'tenant:1000:2000'


Additional info:
----------------
Virtual setup : 3controllers + 2computes + 3ceph

Comment 2 Assaf Muller 2017-01-23 13:25:44 UTC
Confirmed to hit QE CI phase 1:
https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/qe-phase1-11_director-rhel-7.3-virthost-1cont_1comp_1ceph-ipv4-vxlan-ceph/24/

Looking at the build artifacts, OVS agent log on the compute node is showing the same TRACE and VMs cannot be spawned. Network DFG will handle this ASAP.

Comment 4 Dimitri Savineau 2017-01-23 15:19:00 UTC
*** Bug 1414547 has been marked as a duplicate of this bug. ***

Comment 6 Jakub Libosvar 2017-01-25 10:26:07 UTC
This should be fixed in Neutron who doesn't obey minimal version requirements.

Comment 11 errata-xmlrpc 2017-05-17 19:41:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245