Bug 1415896

Summary: rpcbind fails at startup
Product: [Fedora] Fedora Reporter: Thomas Clark <redhat>
Component: rpcbindAssignee: Steve Dickson <steved>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 24CC: rmj, steved, volker
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: rpcbind-0.2.4-4.fc25 rpcbind-0.2.3-17.rc2.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-03 01:36:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Thomas Clark 2017-01-24 02:50:34 UTC
Description of problem: rpcbind fails to start on system startup until the first user interaction, such as rpcinfo.  All programs that depend on rpcbind at startup also fail, including, for example, ypserv, ypbind, rusersd, rstatd.  Some NFS components that normally register with rpcbind, such as nfsd and mountd start, but never register even after rpcbind is running.


Version-Release number of selected component (if applicable): The first affected version is 0.23-15.rc2.fc24. 


How reproducible:  Always


Steps to Reproduce:
1.Reboot the server; all rpcbind-dependent services fail to start
2.
3.

Actual results: rpcbind fails to start


Expected results: rpcbind should start


Additional info: Reverting to rpcbind 0.2.3-10.rc1.fc24 fixes the problem. The same issue exists in fc25, but with different version numbers.

Comment 1 Thomas Clark 2017-01-24 15:33:27 UTC
Sorry for the lack of a dot... the first affected version is actually 0.2.3-15.rc2.fc24.  Also, the first user interaction can be starting a dependent program such as ypserv.  Once the system is running, starting ypserv works, and successfully starts rpcbind.

Comment 2 Fedora Update System 2017-01-28 21:42:06 UTC
rpcbind-0.2.3-17.rc2.fc24 rpcbind-0.2.3-17.rc2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-44ec8c7a0e

Comment 3 Fedora Update System 2017-01-29 23:17:54 UTC
rpcbind-0.2.3-17.rc2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-44ec8c7a0e

Comment 4 Fedora Update System 2017-02-01 21:18:47 UTC
rpcbind-0.2.4-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ad932714f2

Comment 5 Fedora Update System 2017-02-02 22:49:54 UTC
rpcbind-0.2.4-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ad932714f2

Comment 6 Thomas Clark 2017-02-03 01:36:42 UTC
The issue is resolved for both Fedora 24 and Fedora 25.  Thanks for taking care of it so quickly!

Comment 7 Fedora Update System 2017-02-03 20:49:44 UTC
rpcbind-0.2.4-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2017-02-03 21:48:55 UTC
rpcbind-0.2.3-17.rc2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.