Bug 1415985

Summary: 404 page not found for link in oadm drain -h
Product: OpenShift Container Platform Reporter: Weihua Meng <wmeng>
Component: ocAssignee: Juan Vallejo <jvallejo>
Status: CLOSED ERRATA QA Contact: Xingxing Xia <xxia>
Severity: low Docs Contact:
Priority: medium    
Version: 3.5.0CC: aos-bugs, jokerman, jvallejo, mmccomas, tdawson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-04-12 19:10:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Weihua Meng 2017-01-24 10:07:42 UTC
Description of problem:
404 page not found for link in oadm drain -h

Version-Release number of selected component (if applicable):
openshift v3.5.0.8

How reproducible:
Always

Steps to Reproduce:
1. # oadm drain -h
2. open link http://kubernetes.io/images/docs/kubectl _drain.svg


Actual results:
Sorry, this page was not found. :(

Expected results:
Here is the right one. the extra space before '_' results in error.
Please remove the extra space.
https://kubernetes.io/images/docs/kubectl_drain.svg

Additional info:

Comment 1 Juan Vallejo 2017-01-24 19:17:05 UTC
Related PR: https://github.com/openshift/origin/pull/12651

Comment 2 Weihua Meng 2017-01-28 04:26:42 UTC
fixed on openshift v3.5.0.10
the broken link works fine now.

Comment 4 errata-xmlrpc 2017-04-12 19:10:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884