Bug 1416503

Summary: New manifest upload doesn't refresh automatically subscriptions
Product: Red Hat Satellite Reporter: Edu Alcaniz <ealcaniz>
Component: Subscription ManagementAssignee: Eric Helms <ehelms>
Status: CLOSED WONTFIX QA Contact: Katello QA List <katello-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1.9CC: bbuckingham, bkearney, ealcaniz, ehelms, jsherril, malonso
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-19 12:46:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Edu Alcaniz 2017-01-25 16:17:58 UTC
Description of problem:
If we re-register a host to Satellite, we see that a new subscription of type "Red Hat Enterprise Linux Desktop (50 pack), Standard" is created, but previously existing ones are not removed, so we have useless subscriptions created.

Workaround
We have checked and after doing a manifest refresh, duplicated subscriptions disappear, but we would like that this deletion could be done automatically by Satellite rather than after a manual process.


Version-Release number of selected component (if applicable):

Satellite 6.1.9

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
new subscription of type "Red Hat Enterprise Linux Desktop (50 pack), Standard" is created, but previously existing ones are not removed,

Expected results:

Upload a new manifest, refresh all Content hosts and subscriptions

Additional info:

Comment 1 Edu Alcaniz 2017-01-25 16:20:55 UTC
 "It behaves as intended. The desktop subscription SVCRH08V50 is designed for hypervisor, which can host up to 50 virtual desktops. Subscription with sku SVCDSKTPE50 is for physical hosts."

    Yes, it's ok, we understand that those both subscriptions are created, the problem is that the subscription for '50 virtual desktops' associated with the previuos content host id, is not removed.

Comment 8 Edu Alcaniz 2017-03-27 08:10:16 UTC
Do you know if the issue persist on Sat 6.2?

Comment 9 Bryan Kearney 2017-03-27 16:53:21 UTC
MOving the needinfo over to Justin. Justin, do you know if this is the behavior in 6.2?

Comment 10 Justin Sherrill 2017-03-27 17:28:09 UTC
I don't know that the issue is well defined in the original comment, i certainly don't understand the issue that is described. 

Edu, can you properly write out reproducer steps in as clear detail as possible? preferabbly like:

1. First step written out
2. Second step written out
3. etc...

and upload any manifest you used.

Comment 11 Maria Alonso 2017-03-28 08:15:25 UTC
(In reply to Justin Sherrill from comment #10)
> I don't know that the issue is well defined in the original comment, i
> certainly don't understand the issue that is described. 
> 
> Edu, can you properly write out reproducer steps in as clear detail as
> possible? preferabbly like:
> 
> 1. First step written out
> 2. Second step written out
> 3. etc...
> 
> and upload any manifest you used.

Justin,

We have 'Red Hat Enterprise Linux Desktop (50 pack), Premium' type subscriptions for our hosts connected to Satellite.

In order to reproduce the issue you can perform the following steps:

1a. Subscribe a host to an Activation Key

subscription-manager register --org="MyOrg" --activationkey="AK1"

1b. Go to 'Content' --> 'Red Hat Subscriptions', you can see one subscription of type 'Guests of name_of_just_subscribed_host' 

2. Re-subscribe the host to the same or different activation key, you can unregister before, or just add --force parameter, the result is the same

subscription-manager unregister
subscription-manager register --org="MyOrg" --activationkey="AK1"

3. If you go again to 'Content' --> 'Red Hat Subscriptions', you will a new subscription of type 'Guests of name_of_just_subscribed_host', but you can notice that the previous one already exists.

If you put the mouse over the link, you can see the reference to the content host, but only the last one has a valid content host.

So after re-subscription, Satellite seems to delete correctly the previous content host, but the 'Guest of...' type subscription remains.

Let us know if you need more information.

Regards

Comment 12 Justin Sherrill 2017-03-28 12:49:37 UTC
Thanks for that!  

To answer brad's question, yes this should be resolved in 6.2, although I haven't verified that.

Comment 13 Edu Alcaniz 2017-04-03 11:38:49 UTC
(In reply to Justin Sherrill from comment #12)
> Thanks for that!  
> 
> To answer brad's question, yes this should be resolved in 6.2, although I
> haven't verified that.

Do you mind double check please?

Comment 14 Edu Alcaniz 2017-04-17 07:23:14 UTC
Hi, could we have a confirmation about this BZ please

Comment 15 Bryan Kearney 2017-05-19 12:46:08 UTC
We will not be addressing this bug in the 6.1 code base. If you have concerns with this, please feel free to reach out to me with any concerns or issues you may have. Thank you.