Bug 1416750

Summary: SELinux is preventing gnome-directory from 'read' accesses on the file mdstat.
Product: [Fedora] Fedora Reporter: sheepdestroyer <sheepdestroyer>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: dominick.grift, dwalsh, lvrabec, mgrepl, plautrba, pmoore, ssekidde
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:c7dc43fb0e342b6be6d37f3cfacef9879312c9276124a4f9191486e62fd7901d;VARIANT_ID=workstation;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-06 22:54:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description sheepdestroyer 2017-01-26 11:05:16 UTC
Description of problem:
SELinux is preventing gnome-directory from 'read' accesses on the file mdstat.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gnome-directory should be allowed read access on the mdstat file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gnome-directory' --raw | audit2allow -M my-gnomedirectory
# semodule -X 300 -i my-gnomedirectory.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                system_u:object_r:proc_mdstat_t:s0
Target Objects                mdstat [ file ]
Source                        gnome-directory
Source Path                   gnome-directory
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-225.6.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.9.5-200.fc25.x86_64 #1 SMP Fri
                              Jan 20 12:24:16 UTC 2017 x86_64 x86_64
Alert Count                   2
First Seen                    2017-01-24 11:57:21 CET
Last Seen                     2017-01-24 19:47:21 CET
Local ID                      9611a0e5-7550-4398-9bd4-13cbae937e22

Raw Audit Messages
type=AVC msg=audit(1485283641.410:1355): avc:  denied  { read } for  pid=25271 comm="gnome-directory" name="mdstat" dev="proc" ino=4026531975 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=system_u:object_r:proc_mdstat_t:s0 tclass=file permissive=0


Hash: gnome-directory,thumb_t,proc_mdstat_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-225.6.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.9.5-200.fc25.x86_64
type:           libreport

Comment 1 Daniel Walsh 2017-02-06 22:54:09 UTC

*** This bug has been marked as a duplicate of bug 1416749 ***