Bug 1417061

Summary: need a more granular way of resolving split brains automatically based on directory path
Product: Red Hat Gluster Storage Reporter: Nag Pavan Chilakam <nchilaka>
Component: replicateAssignee: Pranith Kumar K <pkarampu>
Status: CLOSED WONTFIX QA Contact: Nag Pavan Chilakam <nchilaka>
Severity: medium Docs Contact:
Priority: low    
Version: rhgs-3.2CC: ksubrahm, ravishankar, rhs-bugs, storage-qa-internal
Target Milestone: ---Keywords: Triaged, ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-16 05:48:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1304593    

Description Nag Pavan Chilakam 2017-01-27 07:08:59 UTC
Description of problem:
-==========================
With BZ#1304593 - Split-brain occurring with one cable pull
we are introducing a way to resolve splitbrains automatically based on favorite child policy and the admin can select based on different policies.
While this is a easy and automated way of resolving split brains,
the admin can have situations where there are say different directories dir1, dir2, and dir3 and say all these directories have more than 100 files in splitbrain

Now the admin may want to resolve splitbrains in dir1 based on mtime
and in dir2 based on ctime
and on dir3 based on size
In the current situation the admin can only set one policy for whole volume.
This means if the admin ends up in above situation he/she may not be able to leverage the automatic resolution feature because the same policy may not fit all the directories.
Instead if we can give option to set splitbrain resolution automatically at directory granularity, it would be more flexible for admin 


Version-Release number of selected component (if applicable):
=======
3.8.4-11