Bug 1417781

Summary: Login Error
Product: Red Hat Enterprise Linux 7 Reporter: Chris <Christopher.Ellenburg>
Component: autofsAssignee: Ian Kent <ikent>
Status: CLOSED WONTFIX QA Contact: Kun Wang <kunwan>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 7.3CC: xifeng, xzhou
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-01-15 07:31:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris 2017-01-31 00:05:33 UTC
Description of problem:
Graphical login immediately kicks users back out after entering password. 
Command line login allows login but gives error:
 -- username: /tilde/username: change directory failed: Permission denied
Logging in with home = "/".

After logging in I can go to the /tilde/username directory and have read/write permissions.

Comment 1 Ian Kent 2017-01-31 00:50:39 UTC
(In reply to Chris from comment #0)
> Description of problem:
> Graphical login immediately kicks users back out after entering password. 
> Command line login allows login but gives error:
>  -- username: /tilde/username: change directory failed: Permission denied
> Logging in with home = "/".
> 
> After logging in I can go to the /tilde/username directory and have
> read/write permissions.

Were you planning on providing more information?
An full debug log for a start would be a good idea.

Comment 2 Chris 2017-01-31 00:52:12 UTC
(In reply to Ian Kent from comment #1)
> (In reply to Chris from comment #0)
> > Description of problem:
> > Graphical login immediately kicks users back out after entering password. 
> > Command line login allows login but gives error:
> >  -- username: /tilde/username: change directory failed: Permission denied
> > Logging in with home = "/".
> > 
> > After logging in I can go to the /tilde/username directory and have
> > read/write permissions.
> 
> Were you planning on providing more information?
> An full debug log for a start would be a good idea.

RedHat isn't my strongest OS. Where can I find the debug log? I'd be glad to provide any information.

Comment 3 Ian Kent 2017-01-31 03:11:24 UTC
(In reply to Chris from comment #2)
> (In reply to Ian Kent from comment #1)
> > (In reply to Chris from comment #0)
> > > Description of problem:
> > > Graphical login immediately kicks users back out after entering password. 
> > > Command line login allows login but gives error:
> > >  -- username: /tilde/username: change directory failed: Permission denied
> > > Logging in with home = "/".
> > > 
> > > After logging in I can go to the /tilde/username directory and have
> > > read/write permissions.
> > 
> > Were you planning on providing more information?
> > An full debug log for a start would be a good idea.
> 
> RedHat isn't my strongest OS. Where can I find the debug log? I'd be glad to
> provide any information.

You will need to enable debug logging in autofs to do this.

Also rsyslog probably won't be recording the facility and level
needed to capture the debug log output.

You could try enabling debug in autofs and checking the systemd
journal log, that might save you the trouble of changing rsyslog.

To enable debug logging in autofs set "logging = debug" in
/etc/autofs.conf. Also ensure that there is no LOGGING setting
in /etc/sysconfig/autofs because that will override the setting
in /etc/autofs.conf (done for backward compatability with older
configuration setups).

To get the autofs logging from the systemd journal you should
be able to do:
journalctl -ae|grep automount

and post the output.

See how you go anyway.
Ian

Comment 6 RHEL Program Management 2021-01-15 07:31:12 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.