Bug 1418103

Summary: mesa-13.0.3-6.fc25 from "updates-testing" breaks bumblebee
Product: [Fedora] Fedora Reporter: Gary Gatling <gsgatlin>
Component: mesaAssignee: Adam Jackson <ajax>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: ajax, esteban.xandri, fschwarz, hdegoede, ignatenko
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-03 10:36:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gary Gatling 2017-01-31 21:22:42 UTC
Description of problem:
mesa-13.0.3-6.fc25 from "updates-testing" breaks bumblebee on my test machine.

Version-Release number of selected component (if applicable):
13.0.3-6

How reproducible:

Install system on nvidia optimus hardware and add third party repo as described here:

https://fedoraproject.org/wiki/Bumblebee


Steps to Reproduce:
1. test primus on command line with 13.0.3-5 with opengl application like glxgears with optirun -b primus or primusrun
2. update to mesa 13.0.3-6 via updates testing.
3. primus can no longer find the required opengl libraries (it seems) after the update and the window will not open.

Actual results:

https://paste.fedoraproject.org/541783/14858971/

Expected results:

Should open a window with spinning gears in it using nvidia openGL.

Additional info:

I believe the problems may be caused by libglvnd. I tried re-compiling primus with the newer mesa*-devel packages but it did not seem to make any difference unfortunately.


Also there is a message on the command line about

/usr/lib64/libGL.so.1: undefined symbol: _glapi_tls_Current

Any ideas about how I can work around this problem? 

I can provide any further logs that might be needed. Thanks.

Comment 1 Hans de Goede 2017-02-01 08:28:44 UTC
Hi,

Can you please contact the upstream bumblebee / primus developers about this ? Using glvnd actually should make things easier for bumlebee since the nvidia binary driver has been using glvnd for a while now.

I guess that some script is playing ldconfig tricks, and that those are no longer necessary now (and are potentially actually causing problems by injecting e.g. an older libglvnd-libGL into the library path).

Regards,

Hans

Comment 2 Gary Gatling 2017-02-02 14:36:26 UTC
I have opened issue 193 on github.com. Thanks.

https://github.com/amonakov/primus/issues/193

Comment 3 Hans de Goede 2017-02-03 10:36:52 UTC
Ok, so lets further track and resolve this upstream.