Bug 1418220

Summary: [RFE] Add support for using ironic-inspector backed by MariaDB + Galera
Product: Red Hat OpenStack Reporter: Ramon Acedo <racedoro>
Component: openstack-ironic-inspectorAssignee: mkovacik
Status: CLOSED ERRATA QA Contact: Dan Yasny <dyasny>
Severity: medium Docs Contact:
Priority: medium    
Version: 11.0 (Ocata)CC: dyasny, lbopf, mburns, mkovacik, mlammon, racedoro, samccann, sclewis, slinaber
Target Milestone: Upstream M3Keywords: FutureFeature, TestOnly, Triaged
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 19:44:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1288035, 1426251    

Description Ramon Acedo 2017-02-01 10:04:16 UTC
ironic-inspector has supported MySQL since Liberty [1]. As part of the ironic-inspector HA implementation, we need to to have ironic-inspector backed by a highly available database, which in our implementation is MariaDB+Galera.

We have a tested ironic-inspector backed by SQLite. This RFE is to test it with MariaDB+Galera as a first step towards a full HA ironic-inspector (bz#1288035)

[1] https://blueprints.launchpad.net/ironic-inspector/+spec/migrate-to-oslodb

Comment 9 errata-xmlrpc 2017-05-17 19:44:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245