Bug 1418459

Summary: rear is poorly documented
Product: Red Hat Enterprise Linux 7 Reporter: Jim Wildman <jwildman>
Component: rearAssignee: Pavel Cahyna <pcahyna>
Status: CLOSED ERRATA QA Contact: David Jež <djez>
Severity: medium Docs Contact: Marie Hornickova <mdolezel>
Priority: unspecified    
Version: 7.3CC: ovasik
Target Milestone: betaKeywords: Documentation, EasyFix, Patch
Target Release: 7.6   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: rear-2.4-2.el7 Doc Type: Enhancement
Doc Text:
The _rear_ package now includes a user guide This update adds the user guide into the _rear_ package, which provides the *Relax-and-Recover* tool (ReaR). After installation of _rear_, you can find the user guide in the `/usr/share/doc/rear-2.4/relax-and-recover-user-guide.html` file.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-30 11:43:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jim Wildman 2017-02-01 21:36:08 UTC
There is no documentation of the configuration options other than in the config directories.

in particular the option AUTOEXCLUDE_MULTIPATH which was suggested in a ticket to a customer is not documented in any Red Hat documentation.

I would like to have all the options fully documented.

Comment 2 Pavel Cahyna 2018-07-17 11:12:05 UTC
AUTOEXCLUDE_MULTIPATH is documented in the user guide, https://github.com/rear/rear/blob/master/doc/user-guide/06-layout-configuration.adoc
One problem is, the user guide is not included in the installed package. This is a problem with the Fedora package as well. I filed a pull request for Fedora, https://src.fedoraproject.org/rpms/rear/pull-request/1 and will look at getting it into the RHEL package.

Comment 6 errata-xmlrpc 2018-10-30 11:43:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3293