Bug 1418522

Summary: make missing %license macro
Product: [Fedora] Fedora Reporter: Stephen Gallagher <sgallagh>
Component: makeAssignee: Patsy Griffin <pfrankli>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: me, pfrankli
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: make-4.2.1-2.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-09 14:52:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1418421    
Attachments:
Description Flags
Patch to add %license sgallagh: review?

Description Stephen Gallagher 2017-02-02 01:43:36 UTC
Created attachment 1246953 [details]
Patch to add %license

Description of problem:
This package contains one or more files containing the package license in the source tarball, but it is not installed on the system with the %license macro. This is important, because the license files will not be installed if the RPM is installed with docs disabled (such as when generating a container base image), which may be a compliance violation.

A provenpackager will apply the attached patch in two weeks if we receive no negative response from the maintainer.