Bug 1418638

Summary: Document steps to create rbd-mirror when both clusters have encrypted OSD's
Product: Red Hat Ceph Storage Reporter: Tejas <tchandra>
Component: DocumentationAssignee: John Wilkins <jowilkin>
Status: CLOSED CURRENTRELEASE QA Contact: Tejas <tchandra>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 2.2CC: asriram, hnallurv, jdillama, kdreyer
Target Milestone: rc   
Target Release: 2.2   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-21 23:50:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tejas 2017-02-02 12:02:07 UTC
Description of problem:
    While creating a rbd-mirror relationship between 2 cluster where both clusters have encrypted OSDs, we need a few additional steps.
This is needed because when encrypted OSDs are present we cannot name the clusters as we want. ( Refer https://bugzilla.redhat.com/show_bug.cgi?id=1391920 ) And due to this both clusters will have name Ceph.

This is needed only till the mentioned BZ is resolved.

In this doc:
https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/paged/block-device-guide/chapter-4-block-device-mirroring

There are 2 separate cluster names used, but when both the cluster names are the same, we need 3 additional  steps to configure rbd-mirror:

1. Change the name of the cluster in the /etc/sysconfig/ceph file on the rbd-mirror node on cluster A (ex: CLUSTER=master )
1a. On ubuntu change the cluster name /etc/default/ceph file.

2. Create a symlink to the ceph.conf file ex: ln -s ceph.conf master.conf    only on the mirror node on cluster A.

3. Use the symlink files in all the rbd-mirror setup. Ex: 'ceph -s' ans 'ceph -s --cluster master' now refer to the same cluster.

Please add a note somewhere in the rbd-mirror segment to reflect this.

Comment 3 Tejas 2017-02-14 12:47:15 UTC
I am not able to access the link. Seems like the server is down.
Is there any other link to access this doc?

Thanks,
Tejas

Comment 4 Tejas 2017-02-15 05:05:51 UTC
Doc looks good to me.
Moving to verified.