Bug 1418694

Summary: missing dependency for atomic-reactor
Product: [Fedora] Fedora EPEL Reporter: Tony Schreiner <anthony.schreiner>
Component: atomic-reactorAssignee: Bohuslav "Slavek" Kabrda <bkabrda>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: admiller, bkabrda, ttomecek, twaugh, vrutkovs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-03 15:52:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tony Schreiner 2017-02-02 14:30:50 UTC
Description of problem:
Currently available python-atomic-reactor package has a requirement for python-docker-squash which is not available

Version-Release number of selected component (if applicable):
python-atomic-reactor-1.6.17-1.el7

How reproducible:
attempt to install or update atomic-reactor (and python-atomic-reactor) leads to the error

Steps to Reproduce:
1. yum update atomic-reactor (from installed version) to version currently in the repo
2.
3.

Actual results:
Resolving Dependencies
--> Running transaction check
---> Package atomic-reactor.noarch 0:1.6.3-1.el7 will be updated
---> Package atomic-reactor.noarch 0:1.6.17-1.el7 will be an update
---> Package python-atomic-reactor.noarch 0:1.6.3-1.el7 will be updated
---> Package python-atomic-reactor.noarch 0:1.6.17-1.el7 will be an update
--> Processing Dependency: python-docker-squash >= 1.0.0-0.3 for package: python-atomic-reactor-1.6.17-1.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-atomic-reactor-1.6.17-1.el7.noarch (epel)
           Requires: python-docker-squash >= 1.0.0-0.3


Expected results:


Additional info:
Related to bugzilla 1356129

Comment 1 Tim Waugh 2017-02-03 15:52:11 UTC

*** This bug has been marked as a duplicate of bug 1356129 ***