Bug 1418697

Summary: [RFE] Develop a tool for comparing multiple Preupgrade Assistant reports (preupg-diff)
Product: Red Hat Enterprise Linux 6 Reporter: Michal Bocek <mbocek>
Component: preupgrade-assistantAssignee: Michal Bocek <mbocek>
Status: CLOSED ERRATA QA Contact: Alois Mahdal <amahdal>
Severity: unspecified Docs Contact: Jiri Hornicek <jhornice>
Priority: unspecified    
Version: 6.9CC: jhornice, jreznik, lkuprova, ovasik, phracek
Target Milestone: rcKeywords: Extras, FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: preupgrade-assistant-2.3.2-1.el6 Doc Type: Release Note
Doc Text:
A new *preupg-diff* tool improves the comparison of the Preupgrade Assistant assessment results Previously, manual comparison of the Preupgrade Assistant assessment results that contained a lot of records was laborious. This update introduces a new *preupg-diff* tool, which compares multiple Preupgrade Assistant XML reports. One of the reports is new with unidentified problems, and the others have already been analyzed. The tool helps to find issues that emerged in the new report by filtering out results that are the same in the new report and in at least one of the analyzed XML files. The output of the trimmed report is given in the XML and HTML format.
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-21 12:11:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michal Bocek 2017-02-02 14:39:34 UTC
Develop a new tool (named preupg-diff) that would compare multiple Preupgrade Assistant XML reports from which one would be "new" (not analyzed by anybody) with unknown issues and the others would be already analyzed.

The tool would help to find new issues that emerged in the new report by filtering out those results that are the same in the new report and at least in one of the analyzed XMLs. The trimmed report should be output in XML and HTML format.

Comment 2 Michal Bocek 2017-02-09 10:39:06 UTC
Prepared in upstream: https://github.com/upgrades-migrations/preupgrade-assistant/pull/216

Comment 4 Alois Mahdal 2017-03-18 14:40:51 UTC
preupgrade-assistant-2.3.3-2.el6: Ran some rudimentary tests manually with real modules, as well as few cases of automated modules.  All seems fine.

Comment 6 errata-xmlrpc 2017-03-21 12:11:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0819.html