Bug 1418750

Summary: Rebase rubygem-abrt to the latest upstream release.
Product: Red Hat Enterprise Linux 7 Reporter: Vít Ondruch <vondruch>
Component: rubygem-abrtAssignee: Vít Ondruch <vondruch>
Status: CLOSED ERRATA QA Contact: Miroslav Hradílek <mhradile>
Severity: unspecified Docs Contact: Lenka Špačková <lkuprova>
Priority: unspecified    
Version: 7.4CC: briang, isenfeld, jberan, mhradile, vondruch
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rubygem-abrt-0.3.0-1.el7 Doc Type: Release Note
Doc Text:
_rubygem-abrt_ rebased to version 0.3.0 The _rubygem-abrt_ package has been rebased to version 0.3.0, which provides several bug fixes and enhancements over the previous version. Notably: * The *Ruby ABRT* handler now supports `uReports`, automatic anonymous microreports. With `uReports` enabled, developers are promptly notified about application issues and are able to fix bugs and resolve problems faster. * Previously, when a *Ruby* application was using *Bundler* to manage its dependencies and an error occurred, an incorrect logic was used to load components of the *Ruby ABRT* handler. Consequently, an unexpected `LoadReport` error was reported to the user instead of a proper *ABRT* report. The loading logic has been fixed, and the *Ruby* application errors are now correctly handled and reported using *ABRT*.
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-01 17:02:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1393868    

Description Vít Ondruch 2017-02-02 16:10:34 UTC
The latest upstream release fixes issues such as:

~~~
/usr/share/gems/gems/abrt-0.1.1/lib/abrt.rb:6:in `require': cannot load such file -- abrt/handler (LoadError)
	from /usr/share/gems/gems/abrt-0.1.1/lib/abrt.rb:6:in `block in <top (required)>'
~~~

This issues could be noticed using Bundler to manage an application dependencies and while the issues are not fatal, they caused that the Ruby problems were not propertly reported by ABRT.

Also, the latest upstream release is adding support for uReports, which were introduced in RHEL 7.3 (rhbz#1334604).

Comment 5 Vít Ondruch 2017-03-27 15:22:59 UTC
As it turns out, there might be (and always were) issues when ABRT daemont is not installed/running. I fixed this via [1] and released rubygem-abrt 0.3.0 [2]. I'll use this opportunity to fix this in RHEL as well.




[1] https://github.com/voxik/abrt-ruby/commit/716fc76eee8436be82d826e04d7af5d165f8c6a7
[2] https://github.com/voxik/abrt-ruby/releases/tag/v0.3.0

Comment 11 errata-xmlrpc 2017-08-01 17:02:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2015