Bug 141897

Summary: fails to create /dev/cdrom after upgrade to 10.FC3.4
Product: [Fedora] Fedora Reporter: Paul Burns <paul-redhat>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: paskalis
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: udev-039-10.FC3.5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-12-07 06:16:24 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Paul Burns 2004-12-04 18:17:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I had udev-039-10.FC3.2 installed and /dev/cdrom was being created
properly. Upgraded to udev-039-10.FC3.4 via up2date and /dev/cdrom
symlink fails to be created in much the same way (superficially, at
least) as when using udev-039-10.FC3.1.

I believe at the time that up2date identified the new release of udev
I was running the latest versions of everything else (i.e. I think
udev was the only package upgraded)

I have since successfully downgraded to udev-039-10.FC3.2 and things
are working as normal again.

Version-Release number of selected component (if applicable):
udev-039-10.FC3.4

How reproducible:
Always

Steps to Reproduce:
1. Started with a working FC3 system with latest updates as of 3rd Dec
2. Updated udev package and rebooted
3. /dev/cdrom symlink is missing. CD player won't work etc.
    

Additional info:
Problem can be fixed by downgrading with:
rpm -e --nodeps udev
rpm -i udev-039-10.FC3.2.rpm
Comment 1 Harald Hoyer 2004-12-06 06:37:57 EST
hmm, very strange...
what does:
# cat /proc/sys/dev/cdrom/info

say on your system?
Comment 2 Harald Hoyer 2004-12-06 06:41:46 EST
also which kernel do you use?
Comment 3 Harald Hoyer 2004-12-06 06:53:09 EST
ah, found the bug...
diff -u -r1.19 udev.rules
--- udev.rules  3 Dec 2004 09:42:48 -0000       1.19
+++ udev.rules  6 Dec 2004 11:52:50 -0000
@@ -59,7 +59,8 @@
 KERNEL="fd[0-9]*",             SYMLINK="floppy%e"
 KERNEL="nst[0-9]*",            SYMLINK="tape%e"

-
+# do not seperate the next 2 lines!!
+KERNEL="hd[a-z]",  BUS="ide", SYSFS{removable}="1",
PROGRAM="/etc/udev/scripts/ide-media.sh %k", RESULT="floppy",
SYMLINK="floppy%e", NAME{all_partitions}="%k", NOREMOVE="1"
 KERNEL="hd[a-z]", BUS="ide", SYSFS{removable}="1", RESULT="cdrom",
SYMLINK="cdrom%e"

 KERNEL="hd[a-z]", BUS="ide", SYSFS{removable}="1",
PROGRAM="/etc/udev/scripts/check-cdrom.sh %k DVD", SYMLINK="dvd%e"
@@ -74,6 +75,5 @@
 # rename sr* to scd*
 KERNEL="sr[0-9]*", BUS="scsi", NAME="scd%n"
 KERNEL="hd[a-z]*", BUS="ide", SYSFS{removable}="1", NOREMOVE="1"
-KERNEL="hd[a-z]",  BUS="ide", SYSFS{removable}="1",
PROGRAM="/etc/udev/scripts/ide-media.sh %k", RESULT="floppy",
SYMLINK="floppy%e", NAME{all_partitions}="%k", NOREMOVE="1"

Comment 4 Sarantis Paskalis 2004-12-06 08:24:04 EST
*** Bug 141959 has been marked as a duplicate of this bug. ***
Comment 5 Paul Burns 2004-12-06 15:38:19 EST
[root@panda ~]# cat /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:             hdc
drive speed:            24
drive # of slots:       1
Can close tray:         1
Can open tray:          1
Can lock tray:          1
Can change speed:       1
Can select disk:        0
Can read multisession:  1
Can read MCN:           1
Reports media changed:  1
Can play audio:         1
Can write CD-R:         1
Can write CD-RW:        1
Can read DVD:           1
Can write DVD-R:        0
Can write DVD-RAM:      0
Can read MRW:           1
Can write MRW:          1
Can write RAM:          1


[root@panda ~]# cat /proc/version
Linux version 2.6.9-1.681_FC3 (bhcompile@tweety.build.redhat.com) (gcc
version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)) #1 Thu Nov 18 15:10:10
EST 2004
Comment 6 Paul Burns 2004-12-06 16:02:22 EST
That patch seems to fix it!

Cheers!