Bug 1419031

Summary: Boxes application crashes during the first start each time
Product: [Fedora] Fedora Reporter: Zdenek Chmelar <chmelarz>
Component: gnome-boxesAssignee: Christophe Fergeau <cfergeau>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 25CC: cfergeau, crobinso, feborges, fidencio, gnome-sig, marcandre.lureau, victortoso, virt-maint, zeeshanak
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-07 09:41:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
logs captured during the Boxes load and crash
none
libvirt debug logs captured during the Boxes load and crash none

Description Zdenek Chmelar 2017-02-03 13:27:57 UTC
Created attachment 1247440 [details]
logs captured during the Boxes load and crash

Description of problem:
Each time I start Gnome Boxes, I get the application interface which is loading and then it crashes after a while


Version-Release number of selected component (if applicable):
gnome-boxes-3.22.3-2.fc25.x86_64


How reproducible:
Every time 


Steps to Reproduce:
1. Start Gnome Boxes
2. Boxes loads the VMs
3. Crashes

Actual results:
First start of Boxes ends with a crash each time. Second start is successful after that


Expected results:
Boxes starts during the first launch.


Additional info:
Please see attached log file for logs captured during the app start and its crash

Comment 1 Victor Toso 2017-02-03 14:33:11 UTC
Interesting bits are:

org.gnome.Boxes[2798]: Error setting up default broker: Unable to open qemu+unix:///session: Failed to connect socket to /run/user/1000/libvirt/libvirt-sock': No such file or directory

org.gnome.Boxes[2798]: Boxes:ERROR:app.c:3346:boxes_app_setup_default_source_co: assertion failed: (default_connection != null)

Which is exactly the upstream bug [0] closed as NOTGNOME as [1] is the reason for it.

[0] https://bugzilla.gnome.org/show_bug.cgi?id=751696
[1] https://bugzilla.redhat.com/show_bug.cgi?id=1259070

Quoting Cole there:
> If people hit the occasional VM startup issue in the future, please file a new > bug and provide the (hopefully better) libvirt error message

@Zdenek, can you provide libvirt logs?
@Cole, just to bring this to your attention in case you need more info.

Comment 2 Zdenek Chmelar 2017-02-03 15:03:32 UTC
I just checked /var/log/libvirt/qemu and found it empty :\
Could you guide me how to enable libvirt auditing or logging please?
I will activate it and report asap.

Comment 3 Zdenek Chmelar 2017-02-03 17:19:17 UTC
I activated debug level of logging with

log_level = 1
log_outputs="1:syslog:libvirtd"

in /etc/libvirt/libvirtd.conf file and restarted libvirtd service but I still do not see any log file anywhere. Moreover, each start of Boxes is successful at the first attempt now. Anyway, I will watch it and try to report more details. Hints how to activate libvirt logging are still welcomed.

Comment 4 Zdenek Chmelar 2017-02-03 17:36:25 UTC
Ok, I fixed logging with 

log_level = 1
log_filters="3:remote 4:event 3:json 3:rpc"
log_outputs="1:file:/var/log/libvirt/libvirtd.log"

and get the file attached in the ticket now.

Comment 5 Zdenek Chmelar 2017-02-03 17:37:26 UTC
Created attachment 1247543 [details]
libvirt debug logs captured during the Boxes load and crash

Comment 6 Zeeshan Ali 2017-02-07 09:41:28 UTC

*** This bug has been marked as a duplicate of bug 1357556 ***