Bug 1419048

Summary: FTBFS?
Product: [Fedora] Fedora Reporter: Neal Becker <ndbecker2>
Component: juliaAssignee: Milan Bouchet-Valat <nalimilan>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: nalimilan, ndbecker2, rosset.filipe
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-06-17 02:21:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
log none

Description Neal Becker 2017-02-03 14:24:35 UTC
Description of problem:
I attempted rpm -i julia-0.5.0-1.fc25.src.rpm 
rpmbuild -bb julia.spec:
... 
Exception running test show :
On worker 7:
LoadError: There was an error during testing
 in record at ./test.jl:397
 in do_test at ./test.jl:281
 in include_string at ./loading.jl:441
 in include_from_node1 at ./loading.jl:491
 in macro expansion at ./util.jl:226 [inlined]
 in runtests at /home/nbecker/rpmbuild/BUILD/julia-0.5.0/test/testdefs.jl:7
 in #16 at /home/nbecker/rpmbuild/BUILD/julia-0.5.0/test/runtests.jl:44
 in #625 at ./multi.jl:1421
 in run_work_thunk at ./multi.jl:1001
 in macro expansion at ./multi.jl:1421 [inlined]
 in #624 at ./event.jl:68
while loading /home/nbecker/rpmbuild/BUILD/julia-0.5.0/test/show.jl, in expression starting on line 386
Exception running test ranges :
On worker 9:
LoadError: There was an error during testing
 in record at ./test.jl:397
 in do_test at ./test.jl:281
 in include_string at ./loading.jl:441
 in include_from_node1 at ./loading.jl:491
 in macro expansion at ./util.jl:226 [inlined]
 in runtests at /home/nbecker/rpmbuild/BUILD/julia-0.5.0/test/testdefs.jl:7
 in #16 at /home/nbecker/rpmbuild/BUILD/julia-0.5.0/test/runtests.jl:44
 in #625 at ./multi.jl:1421
 in run_work_thunk at ./multi.jl:1001
 in macro expansion at ./multi.jl:1421 [inlined]
 in #624 at ./event.jl:68
while loading /home/nbecker/rpmbuild/BUILD/julia-0.5.0/test/ranges.jl, in expression starting on line 584
ERROR: LoadError: Some tests exited with errors.
 in (::##11#19)() at /home/nbecker/rpmbuild/BUILD/julia-0.5.0/test/runtests.jl:72
 in cd(::##11#19, ::String) at ./file.jl:59
 in include_from_node1(::String) at ./loading.jl:488
 in process_options(::Base.JLOptions) at ./client.jl:262
 in _start() at ./client.jl:318
while loading /home/nbecker/rpmbuild/BUILD/julia-0.5.0/test/runtests.jl, in expression starting on line 26
Makefile:12: recipe for target 'all' failed
make[1]: *** [all] Error 1
make[1]: Leaving directory '/home/nbecker/rpmbuild/BUILD/julia-0.5.0/test'
Makefile:572: recipe for target 'test' failed
make: *** [test] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.3lEDc1 (%check)



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Milan Bouchet-Valat 2017-02-03 15:30:16 UTC
Please provide the full logs. Also, what Fedora version are you using? The build passes on Koji AFAIK.

Comment 2 Neal Becker 2017-02-03 18:48:17 UTC
Created attachment 1247556 [details]
log

build log attached
system is fedora 25 with all updates

Comment 3 Milan Bouchet-Valat 2017-02-03 23:26:25 UTC
So the error is:
	From worker 6:	     [1m*[0m [31mshow                 [0mTest Failed
	From worker 6:	  Expression: replstr((collect(1.0:100.0))') == "1×100 Array{Float64,2}:\n 1.0  2.0  3.0  4.0  5.0  6.0  7.0  …  95.0  96.0  97.0  98.0  99.0  100.0"
	From worker 6:	   Evaluated: "1×100 Array{Float64,2}:\n 1.0  2.0  3.0  4.0  5.0  6.0  7.0  8.0  9.0  10.0  …  93.0  94.0  95.0  96.0  97.0  98.0  99.0  100.0" == "1×100 Array{Float64,2}:\n 1.0  2.0  3.0  4.0  5.0  6.0  7.0  …  95.0  96.0  97.0  98.0  99.0  100.0"

That's kind of weird. Could be due to the terminal width being different from the expected one. Are you using something special?

Would also be interesting to reproduce with the julia-nightlies Copr RPMs. If that doesn't happen there, I wouldn't care too much since Julia 0.6 is going to be released soon anyway.

Comment 4 Neal Becker 2017-02-04 13:28:35 UTC
Ah, if it is sensitive to the tty, it could be because it was running under emacs shell.

Comment 5 Milan Bouchet-Valat 2017-02-04 16:15:22 UTC
That's probably it. Please try to reproduce the bug with the upstream source tarball, and file a bug upstream.