Bug 1419947

Summary: [DOCS] Remove tech preview documentation for Jolokia Java Console
Product: OpenShift Container Platform Reporter: Travis Rogers <trogers>
Component: DocumentationAssignee: Michael Burke <mburke>
Status: CLOSED CURRENTRELEASE QA Contact: Vikram Goyal <vigoyal>
Severity: urgent Docs Contact: Vikram Goyal <vigoyal>
Priority: urgent    
Version: 3.4.0CC: aileenc, aos-bugs, jokerman, kconner, mmccomas, pdwyer, trogers
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-20 14:52:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Travis Rogers 2017-02-07 13:35:31 UTC
Document URL: 
https://access.redhat.com/documentation/en/openshift-container-platform/3.4/single/architecture/#jvm-console

Section Number and Name: 
2.3.6. JVM Console

Describe the issue: 
Please remove the "Note" stating that this is tech preview.

Remove this text:
NOTE
This feature is currently in Technology Preview and not intended for production use.

Comment 1 Travis Rogers 2017-02-07 13:43:10 UTC
Please make the change to this product documentation as well

https://access.redhat.com/documentation/en/openshift-container-platform/3.3/single/architecture/#jvm-console

Comment 2 Michael Burke 2017-02-15 17:25:53 UTC
I removed the Technology Preview wording from the Java Console section.

See preview:
http://file.rdu.redhat.com/~mburke/021517/web_console.html

Comment 3 openshift-github-bot 2017-02-15 20:34:25 UTC
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/f9c9e07a345c55f56000668ff1a320945b2d97fd
Merge pull request #3754 from mburke5678/mburke-BZ-1419947-2

Bug 1419947 Removed Technology Preview Wording

Comment 4 Aileen 2017-02-16 23:00:48 UTC
Moving a feature from tech preview to GA requires more than a doc update. How much QE has been done on this features? Normally Tech Preview features get minimal testing. 

Will moving this to GA result in a heavier workload for ongoing support as the quality expectations are higher? 

We are currently working on a major update to this console to conform to PatternFly and I would recommend keeping it a tech preview until this version is available.

Comment 5 Vikram Goyal 2017-02-17 02:48:31 UTC
Travis - since you reported this bug, can you comment?

Comment 6 RHEL Program Management 2017-02-20 14:52:46 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 7 Travis Rogers 2017-02-22 23:55:39 UTC
@Aileen

I posted this as the cloud enablement was surprised to see that Jolokia and the java console were still considered tech preview.  We've considered them supported for close to a year.

Comment 8 kconner 2017-02-23 01:24:11 UTC
+1 Jolokia integration has been the approved mechanism through which we have given access to the Cloud Enablement consoles since OSE 3.1.  It came as a big surprise to us when we recently discovered the documentation still had it as TP.

The integration was done on the OpenShift side so not sure how much testing was specifically done on the console; I would be very interested to find out the scope of this work.

Comment 9 Aileen 2017-03-06 15:57:08 UTC
It seems that the doc has already been updated to remove the Tech Preview status but to close the loop here we reviewed the test plan provided by Xiaoli and as QE already have a good level of coverage in their tests we (eng team) are Ok with declaring this console GA.