Bug 142002

Summary: Default Locale / Konqueror problems
Product: Red Hat Network Reporter: Michael Bowman <mbowman>
Component: RHN/R&DAssignee: Mike McCune <mmccune>
Status: CLOSED CURRENTRELEASE QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: RHN Devel   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-12-06 22:41:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 125080    

Description Michael Bowman 2004-12-06 17:55:02 UTC
Description of problem:
l18n in Konqueror doesn't work. Looks like Konqueror isn't sending the
locale struts is expecting. When we output strings in actual java code
using the localization service, it works. When we output strings via
the bean tag in a jsp, localization doesn't work. 

I think this is because we set the default locale in
localizationService.java, but we don't have a default resource bundle
for the bean tag. Struts in Action says that resource bundles follow
an inheritance tree so StringResource_en_US.properties inherits from
StringResource.properties (thereby setting StringResource.properties
as the default locale).

I've tried copying StringResource_en_US.xml to StringResource.xml, but
it doesn't work.

If you need more info on the problem, call or msg me.


Version-Release number of Konqueror:
3.1.3-5.4 (Default on RHEL 3 WS)