Bug 1420165

Summary: Missing info about generator in "oc expose -h"
Product: OpenShift Container Platform Reporter: Xingxing Xia <xxia>
Component: ocAssignee: Juan Vallejo <jvallejo>
Status: CLOSED ERRATA QA Contact: Xingxing Xia <xxia>
Severity: low Docs Contact:
Priority: low    
Version: 3.3.0CC: aos-bugs, ffranz, jokerman, jvallejo, mmccomas, tdawson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: There was no information about the `--generator` parameter explaining its use in the help output of `oc expose`. Consequence: The parameter was undocumented to users attempting to use the command. Fix: An explanation was added that gave examples on how the `--generator` parameter should be used. Result: The `--generator` parameter is now documented with examples in the output of `oc expose -h`.
Story Points: ---
Clone Of: 1409761 Environment:
Last Closed: 2017-04-12 19:12:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 1 Xingxing Xia 2017-02-08 02:07:13 UTC
Better to update generator usage in command line "oc expose -h" help info too. Thanks!

Comment 2 Juan Vallejo 2017-02-10 22:21:35 UTC
Related PR: https://github.com/openshift/origin/pull/12925

Comment 3 Fabiano Franz 2017-02-18 21:54:08 UTC
Fixed in https://github.com/openshift/origin/pull/12925.

Comment 4 Troy Dawson 2017-02-21 22:37:07 UTC
This has been merged into ocp and is in OCP v3.5.0.32 or newer.

Comment 6 Xingxing Xia 2017-02-22 03:27:18 UTC
Verified in oc v3.5.0.32. 'oc expose -h' has good info for generator now as the PR shows. Thanks!

Comment 8 errata-xmlrpc 2017-04-12 19:12:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884