Bug 1420471

Summary: Update efidefault to only contain distros that are uefi installable.
Product: [Community] Beaker Reporter: Anthony Gialluca <agialluc>
Component: lab controllerAssignee: Dan Callaghan <dcallagh>
Status: CLOSED CURRENTRELEASE QA Contact: Dan Callaghan <dcallagh>
Severity: high Docs Contact:
Priority: urgent    
Version: 24CC: alemay, dcallagh, drohwer, mjia, rfreiss, rjoost
Target Milestone: 24.4Keywords: FutureFeature, Patch
Target Release: ---   
Hardware: All   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-10-03 03:57:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Anthony Gialluca 2017-02-08 18:54:38 UTC
Description of problem:
At present the efidefault file generated by beaker_pxemenu contains distros that cannot boot uefi (ex. RHEL5). Please correct so that when the efidefault is created it does not include these distros.

The distros that should be within are RHEL6 64 bit and CENTOS 64 bit and above.

At present the efidefault file is getting to be too big.

Version-Release number of selected component (if applicable):


How reproducible:
grub/efidefault is created by cron.hourly.


Actual results:
At present, the hourly efidefault is too big and causing provisioning failures. At present some distros where removed to reduce the size of of efidefault on the Boston Lab controller. Then the file was made immutable to prevent cron from overwriting it.

Comment 1 Dan Callaghan 2017-03-28 07:38:43 UTC
Rather than doing some logic like "RHEL6 or above" (which then excludes any bizarre new product names that crop up, like Pegas) I guess we just want to exclude:

* i386 trees of any kind (I thought it already did this?)
* RedHatEnterpriseLinux3 family
* RedHatEnterpriseLinux4 family
* RedHatEnterpriseLinuxServer5 family
* RedHatEnterpriseLinuxClient5 family

Comment 2 Dan Callaghan 2017-03-28 07:49:23 UTC
BTW how big is "too big"? What exactly is the error/bad behaviour that you see?

How do we prevent it just hitting that same problem again, further down the track when we have accumulated more EFI-compatible distros?

Maybe a better solution is to just get all our systems booting GRUB2 instead of GRUB 0.97 instead -- presumably GRUB2 doesn't suffer this same problem?

Comment 4 Anthony Gialluca 2017-08-11 12:49:46 UTC
I haven't seen any activity to this BZ since I commented on some questions in Comment #3. I wanted to see if there is additional information that I need to provide.

Ques: Would it be possible, in the immediate future to at least get RHEL 3/RHEL 4 and RHEL 5 excluded from the UEFI menu ?  That would at least provide some time for a final solution.

Comment 5 Dan Callaghan 2017-08-15 07:29:21 UTC
Are you sure about not moving to GRUB2 though? Was EFI GRUB 0.97 *ever* a supported netboot loader on any RHEL release (apart from Fedora 18)? Do we really have systems which boot successfully with EFI GRUB 0.97 but not with a recent GRUB2?

I can certainly put in some hacks to exclude RHEL3-5 but ultimately the EFIGRUB menu is going to be unusably long pile of mess, since it doesn't support nesting.

Comment 6 Anthony Gialluca 2017-08-16 14:08:04 UTC
Alemay:  Can you comment on Dan's question about ever migrating to GRUB2 ?

Comment 7 Dan Callaghan 2017-08-18 06:02:56 UTC
https://gerrit.beaker-project.org/5792

Comment 10 Dan Callaghan 2017-10-03 03:57:56 UTC
Beaker 24.4 has been released.