Bug 1421233

Summary: Missing "port" in command in 15.3. Configuring rsyslog on the Centralized Logging Server
Product: Red Hat OpenStack Reporter: Chris Linden <lindomatic>
Component: documentationAssignee: RHOS Documentation Team <rhos-docs>
Status: CLOSED DUPLICATE QA Contact: RHOS Documentation Team <rhos-docs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.0CC: lbopf, lvrabec, mburns, mgrepl, mmalik, plautrba, pvrabec, srevivo, ssekidde
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/3/html/Installation_and_Configuration_Guide/Configuring_the_rsyslog_Server.html
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-16 01:48:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Linden 2017-02-10 16:52:53 UTC
Description of problem: semanage doesn't work


Version-Release number of selected component (if applicable):


How reproducible:
semanage -a -t syslogd_port_t -p udp 514

Steps to Reproduce:
1.semanage -a -t syslogd_port_t -p udp 514
2.
3.

Actual results:
[root@centos7_2 ~]# semanage -a -t syslogd_port_t -p udp 514
usage: semanage [-h]
                
                {import,export,login,user,port,interface,module,node,fcontext,boolean,permissive,dontaudit}
                ...
semanage: error: argument subcommand: invalid choice: 'syslogd_port_t' (choose from 'import', 'export', 'login', 'user', 'port', 'interface', 'module', 'node', 'fcontext', 'boolean', 'permissive', 'dontaudit')
[root@centos7_2 ~]#



Expected results:


Additional info:

Comment 1 Chris Linden 2017-02-11 09:25:15 UTC
That is an error on: 
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/3/html/Installation_and_Configuration_Guide/Configuring_the_rsyslog_Server.html

in semanage -a -t syslogd_port_t -p udp 514
"port" is missing:
semanage port -a -t syslogd_port_t -p tcp 514

Further it works just if those are set:
net.ipv4.conf.all.rp_filter = 0
net.ipv4.conf.default.rp_filter = 0
It's not mentioned in the howto.

Cheers,
Chris

Comment 2 Chris Linden 2017-02-11 09:27:56 UTC
You can close this out. I can't do it or don't find how to do it.

Comment 4 Lucy Bopf 2017-02-16 01:48:47 UTC
Thanks, Chris. The same error was reported in bug 1354663, so I'm closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 1354663 ***