Bug 1421868

Summary: Package version needs updating to allow upgrading from Newton to Ocata
Product: Red Hat OpenStack Reporter: Brent Eagles <beagles>
Component: python-networking-odlAssignee: Mike Kolesnik <mkolesni>
Status: CLOSED ERRATA QA Contact: Itzik Brown <itbrown>
Severity: unspecified Docs Contact:
Priority: urgent    
Version: 11.0 (Ocata)CC: jschluet, mcornea, mkolesni, nyechiel, rhos-flags
Target Milestone: rcKeywords: AutomationBlocker
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-networking-odl-4.0.1-0.20170217075916.b46fbe1.el7ost Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: Environment:
N/A
Last Closed: 2017-05-17 19:59:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Brent Eagles 2017-02-13 22:25:07 UTC
Description of problem:

The current build of python-networking-odl  for RDO newton is 3.2.0, but the version being build on master/Ocata is still 3.1.1. This is causing failures in upgrade testing with the only workaround to uninstalled python-network-odl.

Comment 2 Mike Kolesnik 2017-02-19 10:36:42 UTC
I see that RDO trunk [1] already has the latest version (4.0.x) building, how do we get this downstream?

The downstream code should be following stable/ocata branch which was cut last week.

[1] https://trunk.rdoproject.org/centos7-master/report.html

Comment 5 Itzik Brown 2017-02-28 13:43:41 UTC
Before:
python-networking-odl-3.2.0-2.el7ost.noarch

After:
python-networking-odl-4.0.1-0.20170222233838.15ba80f.el7ost.noarch

Comment 7 errata-xmlrpc 2017-05-17 19:59:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245