Bug 1422650

Summary: Services with nil service_template will fail while looking up atomic? or composite?
Product: Red Hat CloudForms Management Engine Reporter: Satoe Imaishi <simaishi>
Component: ProvisioningAssignee: Drew Bomhof <dbomhof>
Status: CLOSED ERRATA QA Contact: Milan Falešník <mfalesni>
Severity: medium Docs Contact:
Priority: high    
Version: unspecifiedCC: jhardy, obarenbo, simaishi
Target Milestone: GAKeywords: ZStream
Target Release: 5.7.2   
Hardware: x86_64   
OS: Linux   
Whiteboard: automate
Fixed In Version: 5.7.2.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1419730 Environment:
Last Closed: 2017-04-12 14:38:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1419730    
Bug Blocks:    

Comment 2 CFME Bot 2017-03-03 18:25:57 UTC
New commit detected on ManageIQ/manageiq/euwe:
https://github.com/ManageIQ/manageiq/commit/f61a7f1c15677afa121a82db4cdbe158304573f5

commit f61a7f1c15677afa121a82db4cdbe158304573f5
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Thu Feb 9 11:45:55 2017 -0500
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Fri Mar 3 13:25:06 2017 -0500

    Merge pull request #13785 from syncrou/service_without_service_template
    
    Power state for services that do not have an associated service_template
    (cherry picked from commit 2de408789d08b5f93421bccbaa1df87078ac2d6f)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1422650

 app/models/service.rb       | 10 ++++++++--
 spec/models/service_spec.rb | 10 ++++++++++
 2 files changed, 18 insertions(+), 2 deletions(-)

Comment 3 Milan Falešník 2017-03-23 11:21:36 UTC
Verified in 5.7.2.0, using rails console I verified that atomic? and composite? work for service without service template.

Comment 5 errata-xmlrpc 2017-04-12 14:38:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:0898