Bug 142598

Summary: sleeping function from invalid context on resume (acpi_os_allocate calls kmalloc with ints off)
Product: [Fedora] Fedora Reporter: Stefan Zechmeister <stefan.zechmeister>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: intel-linux-acpi, jere, pfrields, ronny-rhbugzilla, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 2.6.12-1.1372_FC3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-08-06 07:24:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 165150    

Description Stefan Zechmeister 2004-12-10 20:15:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041204 Firefox/1.0

Description of problem:
after resuming from sleep-state (echo 3 > /proc/acpi/sleep) the error essage at the end is printed in dmesg-output.
this happens with an ibm thinkpad t41p with every package updated.

Stopping tasks: ==========================================================================================|
Back to C!
zapping low mappings.
Debug: sleeping function called from invalid context at mm/slab.c:2063
in_atomic():0[expected: 0], irqs_disabled():1
 [<0211cbcb>] __might_sleep+0x7d/0x8a
 [<0214bf9f>] __kmalloc+0x42/0x7d
 [<021f48e9>] acpi_os_allocate+0xa/0xb
 [<0220878a>] acpi_ut_allocate+0x2e/0x52
 [<02208721>] acpi_ut_initialize_buffer+0x41/0x7c
 [<02205474>] acpi_rs_create_byte_stream+0x23/0x3b
 [<02206976>] acpi_rs_set_srs_method_data+0x1b/0x9d
 [<0211ba78>] scheduler_tick+0x38f/0x4c0
 [<0211b101>] recalc_task_prio+0x128/0x133
 [<0220e15c>] acpi_pci_link_set+0xfe/0x176
 [<0220e4e0>] irqrouter_resume+0x1c/0x24
 [<0224366a>] sysdev_resume+0x3e/0xa5
 [<02246564>] device_power_up+0x5/0xa
 [<0213db9a>] suspend_enter+0x25/0x2d
 [<0213dc08>] enter_state+0x3f/0x5e
 [<0213dd07>] state_store+0x83/0x91
 [<0213dc84>] state_store+0x0/0x91
 [<021ab44b>] subsys_attr_store+0x19/0x21
 [<021ab5be>] flush_write_buffer+0x1d/0x22
 [<021ab5e5>] sysfs_write_file+0x22/0x35
 [<02165c82>] vfs_write+0xb6/0xe2
 [<02165d4c>] sys_write+0x3c/0x62


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. echo 3 > /proc/acpi/sleep
2. resume from sleep
3. dmesg to see the message
  

Actual Results:  i get the described error message.

Expected Results:  no error - acpi fully functional.

Additional info:

Comment 1 Jere Roos 2005-03-11 13:59:22 UTC
I don't know if this is same bug but I can't resume from sleep with
Dell Latitude C640. When resuming from sleep there's text in the
screen which reads "Stopping tasks: ======" etc. and after while
screen goes blank. 
From that point I can only reboot.

Comment 2 Jere Roos 2005-03-11 14:03:12 UTC
Kernel version is 2.6.10-1.770_FC3

Comment 3 Dave Jones 2005-07-15 18:47:31 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 4 petrosyan 2005-07-15 22:09:18 UTC
This bug is still present in kernel-2.6.12-1.1372_FC3
Here is the output from dmesg:

Back to C!
Debug: sleeping function called from invalid context at mm/slab.c:2126
in_atomic():0, irqs_disabled():1
 [<c011d3a4>] __might_sleep+0x9c/0xaa
 [<c0159762>] kmem_cache_alloc+0x3c/0x4c
 [<c023dc0c>] acpi_pci_link_set+0x4a/0x1a2
 [<c023e085>] irqrouter_resume+0x1c/0x24
 [<c027cb02>] sysdev_resume+0x5c/0xac
 [<c0280adb>] device_power_up+0x5/0xa
 [<c014878b>] suspend_enter+0x2d/0x46
 [<c0148727>] suspend_prepare+0x55/0x8c
 [<c0148814>] enter_state+0x39/0x55
 [<c0148931>] state_store+0x92/0xa5
 [<c014889f>] state_store+0x0/0xa5
 [<c01c655b>] subsys_attr_store+0x1f/0x25
 [<c01c6754>] flush_write_buffer+0x25/0x2c
 [<c01c679b>] sysfs_write_file+0x40/0x60
 [<c0177075>] vfs_write+0xaf/0x10a
 [<c017717b>] sys_write+0x41/0x6a
 [<c010392d>] syscall_call+0x7/0xb
hub 3-0:1.0: resubmit --> -108
hub 4-0:1.0: resubmit --> -108
hub 2-0:1.0: resubmit --> -108

Comment 5 Stefan Zechmeister 2005-07-19 20:37:46 UTC
problem  still present with current kernel (2.6.12-1.1372_FC3)

Comment 6 Dave Jones 2005-08-04 19:30:56 UTC
ani, your trace is slightly different (and is a dupe of bug 154046)
Stefan, can you double check your trace is the same as the first one you posted
in this bug ?


Comment 7 Stefan Zechmeister 2005-08-06 07:24:41 UTC
not the same stack trace anymore - the trace now looks like the one from ani! 
i'm closing the bug.

Comment 8 Stefan Zechmeister 2005-08-06 07:37:34 UTC
the stack trace now looks exactly like the one in 164708!

Comment 9 Dave Jones 2005-10-06 04:03:47 UTC
*** Bug 136969 has been marked as a duplicate of this bug. ***