Bug 1425990

Summary: ax25 kernel module is missing in the armv7hl build
Product: [Fedora] Fedora Reporter: Jeff Gustafson <ncjeffgus>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 25CC: cz172638, gansalmon, ichavero, itamar, jonathan, kernel-maint, madhu.chinakonda, mchehab
Target Milestone: ---   
Target Release: ---   
Hardware: armv7hl   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-4.10.10-100.fc24 kernel-4.10.10-200.fc25 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-04-17 20:52:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jeff Gustafson 2017-02-23 00:08:03 UTC
Description of problem:
I am using a RaspberryPi 3 for ham radio. I decided to try Fedora 25 on it, but it appears that the ax25 module file is missing from kernel-modules-extra.

Version-Release number of selected component (if applicable):
kernel-modules-extra-4.9.10-200.fc25.armv7hl

How reproducible:
All kernel-modules-extra for arm are missing the ax25 module.

Steps to Reproduce:
1. Install kernel-modules-extra
2. modprobe ax25
3.

Actual results:
modprobe: FATAL: Module ax25 not found in directory /lib/modules/4.9.10-200.fc25.armv7hl


Expected results:
The ax25 module should load.

Additional info:
The CONFIG_HAMRADIO option is turned off for the kernel build. This option is turned on for x86_64 builds. I had successfully used the ax25 module with the "Fedberry" distro before it was merged with Fedora.

Comment 1 Justin M. Forbes 2017-04-11 14:51:14 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 2 Jeff Gustafson 2017-04-11 19:01:10 UTC
Yes, the issue still exists. The kernel must be re-built with the CONFIG_HAMRADIO option for the RPi platform.

Comment 3 Fedora Update System 2017-04-13 15:32:50 UTC
kernel-4.10.10-200.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-26c9ecd7a4

Comment 4 Fedora Update System 2017-04-13 15:33:50 UTC
kernel-4.10.10-100.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8e7549fb91

Comment 5 Fedora Update System 2017-04-14 23:52:55 UTC
kernel-4.10.10-100.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8e7549fb91

Comment 6 Fedora Update System 2017-04-15 00:28:19 UTC
kernel-4.10.10-200.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-26c9ecd7a4

Comment 7 Fedora Update System 2017-04-17 20:52:14 UTC
kernel-4.10.10-100.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2017-04-17 20:52:41 UTC
kernel-4.10.10-200.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.