Bug 1427792

Summary: RabbitMQ: Bad address when CONFIG_AMQP_ENABLE_SSL=y
Product: Red Hat OpenStack Reporter: Victor Stinner <vstinner>
Component: python-oslo-messagingAssignee: Victor Stinner <vstinner>
Status: CLOSED ERRATA QA Contact: Asaf Hirshberg <ahirshbe>
Severity: high Docs Contact:
Priority: high    
Version: 11.0 (Ocata)CC: apevec, eglynn, fdinitto, fpercoco, jeckersb, jruzicka, jschluet, knakai, lhh, lruzicka, pablo.iranzo, plemenko, pmannidi, sacpatil, sclewis, srevivo, ushkalim, vstinner
Target Milestone: rcKeywords: Triaged, ZStream
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-oslo-messaging-5.17.1-2.el7ost Doc Type: Bug Fix
Doc Text:
The Remote Procedure Call (RPC) message acknowledgement in Oslo Messaging was not thread-safe. Consequently, a race condition caused an RPC timeout in Ceilometer. The message acknowledgement in Oslo Messaging has been fixed. Now, Ceilometer responds correctly.
Story Points: ---
Clone Of: 1423593 Environment:
Last Closed: 2017-05-17 20:03:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1423593    
Bug Blocks:    

Comment 2 Victor Stinner 2017-03-13 14:06:13 UTC
python-oslo-messaging-5.17.1-2.el7ost contains the "rabbit: make ack/requeue thread-safe" and is now ready for tests ;-)

Comment 4 Asaf Hirshberg 2017-03-27 05:51:08 UTC
Code Verified.

Comment 8 errata-xmlrpc 2017-05-17 20:03:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245