Bug 143203

Summary: PCI device 151f:0000 now being reported as 5555:0000
Product: [Fedora] Fedora Reporter: Evan Clarke <evanclarke>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-01-11 05:14:50 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Evan Clarke 2004-12-17 06:01:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I installed the udev-039-10.FC3.6 update this morning, and when I next
turned on my machine kudzu pops up saying that my TOPIC SEMICONDUCTOR
INC 56K FAX MODEM (string from memory - it is an internal 56K modem)
is no longer present.  I removed the config (whilst being confused),
and kudzu then pops up saying it has found a "Genroco, Inc: Unknown
device 0000", and if I wanted to configure it.  I chose yes.

When I next went to use my modem it would not work, as the rc.serial
script I have set up to do the setserial magic was failing as the PCI
identification numbers have changed from 151f:0000 to 5555:0000. 
After modifying my script (essentially a s/151f\:0000/5555\:0000/g)
and manually running it, it now works.

Surely the identification numbers should not be changing.

Version-Release number of selected component (if applicable):
udev-039-10.FC3.6

How reproducible:
Always

Steps to Reproduce:
See description.

Additional info:
Comment 1 Harald Hoyer 2004-12-17 09:04:35 EST
are you sure you only updated udev since the last reboot?
Comment 2 Evan Clarke 2004-12-18 22:36:29 EST
Yes, here is the output from `rpm -qa --last` the verify that:
udev-039-10.FC3.6                             Fri 17 Dec 2004 11:30:30 EST
grep-2.5.1-31.2                               Wed 15 Dec 2004 13:36:52 EST
mikmod-3.1.6-30.2                             Wed 15 Dec 2004 02:04:48 EST
gstreamer-tools-0.8.7-4.FC3.0                 Wed 15 Dec 2004 02:04:48 EST
gstreamer-0.8.7-4.FC3.0                       Wed 15 Dec 2004 02:04:25 EST
shadow-utils-4.0.3-56                         Thu 09 Dec 2004 13:18:02 EST
Omni-foomatic-0.9.2-1.1                       Thu 09 Dec 2004 13:18:00 EST
Omni-0.9.2-1.1                                Thu 09 Dec 2004 13:17:51 EST
rhpl-0.148.1-2                                Wed 08 Dec 2004 16:09:57 EST
[snip]

The only other thing I can think of is I have added an internal PCI
USB2.0 host card, but that was several boot cycles ago - and there
have been no problems during those boot cycles.
Comment 3 Harald Hoyer 2004-12-21 11:04:57 EST
could you go back to udev-039-10.FC3.5 and see, if that changes anything?
Comment 4 Evan Clarke 2005-01-11 05:14:50 EST
Sorry for late follow-up.  Was away for a while and request for
MOREINFO got lost in the sea of mail when I got back.

Closing the bug - seems my card/something else is playing up as it has
been functioning fine now with the current version of udev without
changing anything.

Maybe there needs to be a Resolved: PHASEOFTHEMOON resolution :-)