Bug 1432874

Summary: No More Alphas
Product: [Fedora] Fedora Reporter: Jan Kurik <jkurik>
Component: Changes TrackingAssignee: Dennis Gilmore <dennis>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: awilliam, dennis, dgilmore
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ChangeAcceptedF27, SystemWideChange
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-14 08:57:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jan Kurik 2017-03-16 09:58:00 UTC
This is a tracking bug for Change: No More Alphas
For more details, see: https://fedoraproject.org//wiki/Changes/NoMoreAlpha

Fedora will no longer produce Alpha releases.

Comment 1 Jan Kurik 2017-08-10 06:17:54 UTC
On 2017-Aug-01, we have reached the Fedora 27 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be enabled at Change Completion deadline as well.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo for 2017-Aug-11 meeting.

Please set this bug to the MODIFIED state to indicate it is already in the testable state, or provide an update describing the current state of implementation for this Change.

Thank you,
Jan

Comment 2 Adam Williamson 2017-08-10 21:35:36 UTC
It's a bit difficult to 'test' a negative...but current state is that the required changes to process documentation are in draft and being reviewed on the mailing lists, and there's a working prototype of the script to check whether a compose is 'releasable':

https://pagure.io/fedora-qa/lolz_and_roffle/tree/master

but we haven't cleaned it up and deployed it in releng use yet. I'm not sure of the status of the part of the proposal that involves gating package builds on automated tests.

Comment 3 Jan Kurik 2017-08-14 14:28:22 UTC
Discussed on FESCo meeting on 2017-08-11 : https://meetbot.fedoraproject.org/teams/fesco/fesco.2017-08-11-16.01.log.html#l-551

Considered as "testable" -> moving to MODIFIED.

Comment 4 Jan Kurik 2017-08-15 08:08:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 5 Jan Kurik 2017-09-06 13:38:12 UTC
On 2017-Sep-05 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 27 release. At this point all the Changes not at least in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan

Comment 6 Adam Williamson 2017-09-06 14:43:36 UTC
There's no 'code' to speak of in terms of not shipping Alphas any more, and we're handling the process side of it fine. Compose gating is not done at all, however; we're now planning to implement it via Greenwave (since it's exactly what Greenwave is for) but it hasn't been a priority since it's been so hard to get composes done *at all* lately.

Comment 7 Jan Kurik 2017-09-19 11:15:35 UTC
Switching to ON_QA based on FESCo comment: https://pagure.io/fesco/issue/1773#comment-465932

Comment 8 Dennis Gilmore 2018-01-17 17:43:11 UTC
clearing needinfo