Bug 1433527 (ovnmetadata)

Summary: [RFE] [Neutron] [OVN] Metadata support
Product: Red Hat OpenStack Reporter: Assaf Muller <amuller>
Component: python-networking-ovnAssignee: Daniel Alvarez Sanchez <dalvarez>
Status: CLOSED ERRATA QA Contact: Eran Kuris <ekuris>
Severity: high Docs Contact:
Priority: medium    
Version: 12.0 (Pike)CC: apevec, chrisw, dalvarez, ekuris, jlibosva, lhh, majopela, nyechiel, rhos-maint, sclewis, srevivo, tfreger
Target Milestone: Upstream M3Keywords: FutureFeature, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-networking-ovn-4.0.0-0.20171205134230.746cae0.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:29:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1498491, 1503796, 1548947    

Description Assaf Muller 2017-03-17 22:56:22 UTC
OpenStack VMs access the neutron metadata service available at the link-local IP address: 169.254.169.254. We want to implement the metadata service in networking-ovn without running DHCP or L3 agents. This possibly requires changes in OVN itself, depending on the approach chosen to resolve this RFE.

Comment 3 Assaf Muller 2017-04-24 13:29:42 UTC
Will require OVS 2.8, pushed to OSP 13.

Comment 5 Daniel Alvarez Sanchez 2017-12-11 14:28:22 UTC
The functionality was merged some time ago and as of today we have still pending some patches in TripleO [0]. Most of the work is done and we're close to finalize it soon.

[0] https://review.openstack.org/#/q/topic:ovn-metadata-agent+(status:open+OR+status:merged)

Comment 11 Daniel Alvarez Sanchez 2018-01-15 09:22:03 UTC
Patches upstream are merged:

https://review.openstack.org/#/q/topic:ovn-metadata-agent+(status:open+OR+status:merged)

Comment 15 Eran Kuris 2018-04-30 09:49:31 UTC
Verified on:
OSP13 p - 2018-04-26.3
python-networking-ovn-4.0.1-0.20180420150809.c7c16d4.el7ost.noarch
test run:
https://polarion.engineering.redhat.com/polarion/#/project/RHELOpenStackPlatform/testrun?id=20180430-0553

Comment 17 errata-xmlrpc 2018-06-27 13:29:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086