Bug 1436075

Summary: embree 2.15.0-1 not built with $RPM_OPT_FLAGS
Product: [Fedora] Fedora Reporter: Ville Skytt√§ <ville.skytta>
Component: embreeAssignee: Luya Tshimbalanga <luya_tfz>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 26CC: luya, luya_tfz, mtasaka, negativo17, ville.skytta
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: embree-2.15.0-2.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-04-01 17:31:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 496968    

Description Ville Skyttä 2017-03-27 05:39:18 UTC
embree 2.15.0-1 is not built with $RPM_OPT_FLAGS, see /usr/bin/c++ lines in the build log: https://kojipkgs.fedoraproject.org//packages/embree/2.15.0/1.fc27/data/logs/x86_64/build.log

2.14.0-2 did not have this problem: https://kojipkgs.fedoraproject.org//packages/embree/2.14.0/2.fc26/data/logs/x86_64/build.log

Comment 1 Luya Tshimbalanga 2017-03-27 21:13:55 UTC
Strange. the spec in 2.15.0-1 has '%{optflags}'
https://src.fedoraproject.org/cgit/rpms/embree.git/tree/embree.spec

%build
pushd %{_target_platform} 
   CXXFLAGS='%{optflags}' %cmake ..
popd

I just scratch built below
https://koji.fedoraproject.org/koji/taskinfo?taskID=18638019

adding "-Wno-all -Wformat" which should enable %{optflags}

Comment 2 Mamoru TASAKA 2017-03-28 06:05:48 UTC
This is because of this change:
https://github.com/embree/embree/commit/e2187611a542749f7571bcda5e793e497512e967

Using
CXXFLAGS='%{optflags}' %cmake -DEMBREE_IGNORE_CMAKE_CXX_FLAGS:BOOL=off ..
seems good:

https://koji.fedoraproject.org/koji/taskinfo?taskID=18641267

Comment 3 Luya Tshimbalanga 2017-03-28 06:42:19 UTC
You can apply the change. I am unable to do on my side to due to network issue.
Thanks

Comment 4 Mamoru TASAKA 2017-03-28 07:05:27 UTC
(In reply to Luya Tshimbalanga from comment #3)
> You can apply the change. I am unable to do on my side to due to network
> issue.
> Thanks

Okay, then I'll build. By the way I will again merge branches, because F-24/F-25/F-26/master branches' embree are actually all the same.

Comment 5 Fedora Update System 2017-03-28 08:10:34 UTC
LuxRender-1.6-13.fc26 embree-2.15.0-2.fc26 ispc-1.9.1-11.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a10331aece

Comment 6 Fedora Update System 2017-03-28 17:53:35 UTC
LuxRender-1.6-13.fc26, embree-2.15.0-2.fc26, ispc-1.9.1-11.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a10331aece

Comment 7 Fedora Update System 2017-04-01 17:31:44 UTC
LuxRender-1.6-13.fc26, embree-2.15.0-2.fc26, ispc-1.9.1-11.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.