Bug 1436767

Summary: Alerting DefinitionsEvents might have a wrong order on import operations
Product: OpenShift Container Platform Reporter: Lucas Ponce <lponce>
Component: HawkularAssignee: Matt Wringe <mwringe>
Status: CLOSED ERRATA QA Contact: Liming Zhou <lizhou>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.5.1CC: aos-bugs, jshaughn, lponce, mwringe, tdawson, wsun
Target Milestone: ---   
Target Release: 3.5.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-18 09:27:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Lucas Ponce 2017-03-28 15:24:48 UTC
There is a potential bug in alerting due wrong order of definitions events on import operations.

When re-importing the same trigger, an internal set used to collect events can be unordered and potentially doesn't not update definitions correctly.

Comment 6 Troy Dawson 2017-04-28 15:54:21 UTC
openshift3/metrics-hawkular-metrics:3.5.0-15

Comment 7 Troy Dawson 2017-04-28 15:54:40 UTC
This fix for this is in image
openshift3/metrics-hawkular-metrics:3.5.0-15

Comment 16 Liming Zhou 2017-05-10 08:38:33 UTC
@jshaughn, @lponce,

Did some test per your suggestion, it works so change the status to verified.
Let me know if anything more to do.

Thanks,
Nicholas

Comment 18 errata-xmlrpc 2017-05-18 09:27:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1235