Bug 1438441 (CVE-2016-10270)

Summary: CVE-2016-10270 libtiff: Heap-based buffer overflow in tiff_read.c
Product: [Other] Security Response Reporter: Andrej Nemec <anemec>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: erik-fedora, mike, nforro, phracek
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-04-03 13:06:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1438464, 1438465, 1438466    
Bug Blocks:    

Description Andrej Nemec 2017-04-03 12:42:27 UTC
A heap-buffer overflow vulnerability was found in libtiff. A maliciously crafted file could cause the application to crash.

Upstream patch:

https://github.com/vadz/libtiff/commit/9a72a69e035ee70ff5c41541c8c61cd97990d018

Upstream bug:

http://bugzilla.maptools.org/show_bug.cgi?id=2608

Comment 1 Andrej Nemec 2017-04-03 13:13:37 UTC
Created libtiff tracking bugs for this issue:

Affects: fedora-all [bug 1438464]


Created mingw-libtiff tracking bugs for this issue:

Affects: epel-7 [bug 1438466]
Affects: fedora-all [bug 1438465]