Bug 144

Summary: terminfo files location changed
Product: [Retired] Red Hat Linux Reporter: ondrej.pejsa
Component: ncursesAssignee: Cristian Gafton <gafton>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 5.2CC: ondrej.pejsa
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-11-20 13:35:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ondrej.pejsa 1998-11-20 10:38:12 UTC
I got problems with RH 5.1 & RH 5.2 on i386 and ADABAS D
6.x, adabas text-console utilities (like xquery, xpl etc.)
become wild colored (and some keystrokes are also wrong). I
found, that due new location of terminfo files
(/usr/share/terminfo instead of /usr/lib/terminfo). When I
created symlink /usr/lib/terminfo -> /usr/share/terminfo,
things become right again.
So i think that RH 5.x instalation should create this
symlink automaticly.

Comment 1 Cristian Gafton 1998-11-20 13:35:59 UTC
This is one of the RPM shortcomings - we can not reliably replace one
directory with a symlink to another directory when upgrading the rpm.

This will take some engineering efforts to fix it in the rpm and
terminfo is not the only package that experiences problems because of
that. Basically only the programs that have ncurses linked statically
in experience this problem. As always, staically linking libraries
into executables is a BAD thing.

Comment 2 Preston Brown 1998-11-23 12:14:59 UTC
*** Bug 151 has been marked as a duplicate of this bug. ***

Comment 3 Aleksey Nogin 1998-12-10 05:52:59 UTC
Is it possible to work around this RPM problem by creating symlinks in
the %post script instead of putting symlinks into the package itself?

Comment 4 Cristian Gafton 1998-12-10 23:55:59 UTC
That would work in an idal world where we know that no other package
is providing files under /usr/lib/terminfo. In real life we can not
guarantee that, so doing a "rm -rf /usr/lib/terminfo" on a live
filesystem is a no-go.

Comment 5 Aleksey Nogin 1998-12-11 10:55:59 UTC
What about something like
% post
if [ ! -e /usr/lib/terminfo ]; then
	ln -s /usr/share/terminfo /usr/lib/terminfo
fi

? It's not perfect, but at least harmless and would help some people

Comment 6 Fedora Update System 2020-09-19 22:38:30 UTC
FEDORA-2020-d358d5b0d8 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2020-09-19 22:44:57 UTC
FEDORA-2020-7a574982d6 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-09-25 16:55:34 UTC
FEDORA-2020-0fedf74544 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2020-09-27 01:34:49 UTC
FEDORA-EPEL-2020-66f3795e72 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2020-09-27 01:53:38 UTC
FEDORA-EPEL-2020-7dbefa245f has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.