Bug 1440094

Summary: Can't build RPM for patches that modify neutron setup.cfg file on 10.0.0 tag
Product: Red Hat OpenStack Reporter: Daniel Alvarez Sanchez <dalvarez>
Component: openstack-neutronAssignee: Daniel Alvarez Sanchez <dalvarez>
Status: CLOSED ERRATA QA Contact: Eran Kuris <ekuris>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 11.0 (Ocata)CC: amuller, chrisw, jlibosva, nyechiel, oblaut, srevivo
Target Milestone: rcKeywords: Triaged, ZStream
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-neutron-10.0.0-14.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1440099 (view as bug list) Environment:
Last Closed: 2017-05-17 20:18:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1440099    

Description Daniel Alvarez Sanchez 2017-04-07 09:43:02 UTC
Because the setup.cfg included in U/S neutron tarballs [0] include tabs instead of spaces, and patches expect it to have spaces, rpmbuild can't apply patches that modify this file.

Although there's an RFE [1] to do this, in the meantime we can submit a double patch on top of the latest tagged commit:

1. Patch that uses the setup.cfg from the tarball (with tabs) - DROP-IN-RPM
2. Patch that uses the setup.cfg from git (with spaces and comments)

After this, all git patches that modify setup.cfg should apply and the RPM package should build normally.

[0] https://tarballs.openstack.org/neutron/
[1] https://github.com/openstack-packages/rdopkg/issues/112

Comment 3 Eran Kuris 2017-05-03 08:49:14 UTC
verified 
openstack-neutron-10.0.1-1.el7ost.noarch

Comment 4 errata-xmlrpc 2017-05-17 20:18:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245