Bug 1440647

Summary: /virt/install: aarch64 support
Product: [Community] Beaker Reporter: Artem Savkov <asavkov>
Component: testsAssignee: Dan Callaghan <dcallagh>
Status: CLOSED CURRENTRELEASE QA Contact: Dan Callaghan <dcallagh>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: dcallagh, jstancek, mjia, rjoost
Target Milestone: 24.3   
Target Release: ---   
Hardware: aarch64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-26 07:43:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Artem Savkov 2017-04-10 07:47:24 UTC
Changes are required for /virt/install core task to work on aarch64.
Patch posted for review: https://gerrit.beaker-project.org/#/c/5663/

Comment 1 Dan Callaghan 2017-04-20 07:17:05 UTC
Artëm, could you give us a quick summary of *why* these changes are needed?

I am guessing we take out the console= parameter and add --noautoconsole because the aarch64 guest firmware doesn't have serial console support yet? (Is that really true? Seems like a major deficiency.)

What about --nographics? Is that also a missing feature in the aarch64 KVM guests?

Is it something that will be added in future, in which case this is just a temporary workaround and we should take it out later?

Comment 2 Artem Savkov 2017-04-20 07:50:11 UTC
(In reply to Dan Callaghan from comment #1)
> Artëm, could you give us a quick summary of *why* these changes are needed?
> 
> I am guessing we take out the console= parameter and add --noautoconsole
> because the aarch64 guest firmware doesn't have serial console support yet?
> (Is that really true? Seems like a major deficiency.)
It does have console support and we do get console output with options set like this. None of aarch64 machines we have in beaker have "console" cmdline parameter set, so I removed default "console=ttyS0" that resulted in no output.

> What about --nographics? Is that also a missing feature in the aarch64 KVM
> guests?
> Is it something that will be added in future, in which case this is just a
> temporary workaround and we should take it out later?

qemu-kvm on aarch64 does not support default cirrus vga emulation. It does support virtio vga but since we don't use graphics during testing and ppc64 already does this we came to a conclusion that it will be enough to disable graphics for aarch64 altogether.

Comment 3 Jan Stancek 2017-05-18 08:53:15 UTC
@Dan: Can you please set the flags, so it's included in next beaker release? Any estimate when that will be?

Comment 4 Dan Callaghan 2017-05-19 00:11:22 UTC
I guess we can release this independently of Beaker since it's just a task change.

Comment 5 Dan Callaghan 2017-05-26 00:52:39 UTC
Tagged /distribution/virt/install 4.0-94.

Comment 8 Dan Callaghan 2017-05-26 07:43:50 UTC
/distribution/virt/install 4.0-94 has been released.