Bug 1440876

Summary: Support Pacemaker ACLs
Product: Red Hat Enterprise Linux 7 Reporter: Jan Pokorný [poki] <jpokorny>
Component: clufterAssignee: Jan Pokorný [poki] <jpokorny>
Status: CLOSED ERRATA QA Contact: cluster-qe <cluster-qe>
Severity: medium Docs Contact:
Priority: high    
Version: 7.3CC: cfeist, cluster-maint, idevat, mlisik, mspqa-list, omular, rsteiger, slevine, tlavigne, tojeline
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: clufter-0.75.0-1.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1111369 Environment:
Last Closed: 2017-08-01 23:06:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1111369    
Bug Blocks:    

Description Jan Pokorný [poki] 2017-04-10 16:20:46 UTC
Clufter needs to pcs CLI syntax to add new roles, users and groups in its
{cib,pcs}2pcscmd* commands.  Not doing so has a harmful potential of
dropping access control enforcement when using the respective output to
recreate the cluster configuration, which is naturally expected to
copy the original truthfully (in this sense, it could be betraying).

+++ This bug was initially created as a clone of Bug #1111369 +++

Support for viewing/creating/editing pacemaker ACLs is needed.

Comment 1 Jan Pokorný [poki] 2017-04-10 16:21:59 UTC
s/needs to/needs to support/

Comment 5 errata-xmlrpc 2017-08-01 23:06:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2198