Bug 144107

Summary: Openssh doesn't need pam_nologin
Product: [Fedora] Fedora Reporter: Tomas Mraz <tmraz>
Component: opensshAssignee: Tomas Mraz <tmraz>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: dkelson
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: openssh-4.1p1-2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-09 17:47:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tomas Mraz 2005-01-04 11:54:14 EST
In the /etc/pam.d/sshd there is 'auth required pam_nologin.so' line.

This is however unnecessary because the functionality of this pam
module is duplicated in the sshd source. And the nologin message of
pam_nologin isn't printed. Note that you need pam_nologin of FC2 and
older because of the bug 143750 which efectively disables pam_nologin
for sshd.

The pam_nologin should be removed from the /etc/pam.d/sshd.
Comment 1 Tomas Mraz 2005-06-09 17:47:37 EDT
Fixed the other way around - the direct /etc/nologin processing by sshd was
removed if UsePAM is yes (the default).
Comment 2 Dax Kelson 2006-02-01 12:43:57 EST
(In reply to comment #1)
> Fixed the other way around - the direct /etc/nologin processing by sshd was
> removed if UsePAM is yes (the default).

Was this done with a RH specific patch?

The new (Feb 2006) release of OpenSSH v4.3 does exactly this.
Comment 3 Tomas Mraz 2006-02-01 13:06:57 EST
The upstream fix was based on the FC patch.