Bug 1441891

Summary: [RHEL7.3]Provision RHEL7.3 /RHEL7.4 failed on special server
Product: Red Hat Enterprise Linux 7 Reporter: guazhang <guazhang>
Component: python-blivetAssignee: Blivet Maintenance Team <blivet-maint-list>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Release Test Team <release-test-team>
Severity: high Docs Contact:
Priority: unspecified    
Version: 7.3CC: 51800464, blivet-maint-list, cobrakoral, kasmith, knweiss, me, mvj, schadel0212, thorsten.wagner, vlovejoy
Target Milestone: rcFlags: cobrakoral: needinfo? (blivet-maint-list)
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-03 15:25:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description guazhang@redhat.com 2017-04-13 02:06:40 UTC
Description of problem:
Install rhel7.3 rhel7.4 failed on special server

Version-Release number of selected component (if applicable):
failed job 
rhel7.3
https://beaker.engineering.redhat.com/recipes/3725921#task54388362
rhel7.4
https://beaker.engineering.redhat.com/recipes/3722723#task54352616

pass job:
rhel7.2
https://beaker.engineering.redhat.com/recipes/3729235#task54432644


How reproducible:
100%

Steps to Reproduce:
1.install rhel7.3 or rhel7.4
2.
3.

my server :storageqe-26.rhts.eng.bos.redhat.com
https://beaker.engineering.redhat.com/?simplesearch=storageqe-26
boot disk :NVME
boot mode :UEFI

some days ago ,install rhel7.3 works well.
https://beaker.engineering.redhat.com/recipes/3672414#tasks


Actual results:
error

Expected results:
install success

Additional info:

An unknown error has occured, look at the /tmp/anaconda-tb* file(s) for more details      
      
=============================================================================== 
An unknown error has occurred      
     
=============================================================================== 
anaconda 21.48.22.93-1 exception report 
Traceback (most recent call first): 
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 839, in isNameValid 
    if name.startswith("cciss/"): 
  File "/usr/lib/python2.7/site-packages/blivet/devices/device.py", line 83, in __init__ 
    if not self.isNameValid(name): 
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 131, in __init__ 
    Device.__init__(self, name, parents=parents) 
  File "/usr/lib/python2.7/site-packages/blivet/devices/container.py", line 61, in __init__ 
    super(ContainerDevice, self).__init__(*args, **kwargs) 
  File "/usr/lib/python2.7/site-packages/blivet/devices/md.py", line 103, in __init__ 
    sysfsPath=sysfsPath) 
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1733, in handleUdevMDMemberFormat 
    exists=True) 
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1992, in handleUdevDeviceFormat 
    self.handleUdevMDMemberFormat(info, device) 
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1281, in addUdevDevice 
    self.handleUdevDeviceFormat(info, device)       

  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2310, in _populate 
    self.addUdevDevice(dev) 
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2243, in populate 
    self._populate() 
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 495, in reset      

    self.devicetree.populate(cleanupOnly=cleanupOnly) 
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 190, in storageInitialize 
    storage.reset() 
  File "/usr/lib64/python2.7/threading.py", line 764, in run 
    self.__target(*self.__args, **self.__kwargs) 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run 
    threading.Thread.run(self, *args, **kwargs) 
AttributeError: 'NoneType' object has no attribute 'startswith' 

What do you want to do now? 
1) Report Bug 
2) Debug 
3) Quit 

Traceback (most recent call last): 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run

Comment 2 Thorsten W. 2017-05-18 13:21:25 UTC
We have exactly the same issue with the latest CentOS 7 on our Intel Xeon Phi 7250 server:

This is the specification of our system:

1x Intel® Xeon Phi Processor 7250B0 (34MB Cache, 1.40 GHz, 68 core), (LGA 3647) (MKT0000007126)
192GB (6x 32GB) DDR4 PC2133 ECC
1x 2TB SSD Samsung 850 Pro 2,5" 2 TB,
1x 3.5" convert to 2.5" HDD Tray
4x 6TB SATA3-HDD HGST HUS726060ALE610
ULTRASTAR 7K6000 - # 0F23001- 3.5in 6000GB 128MB 7200RPM SATA 6GB/s 512e – HotSwap

Comment 4 Michael 2017-07-05 06:28:44 UTC
Hi Everyone!

Solved the same issue by booting a rescue mode and then creating new partition table on disks with fdisk. I think it cleared previous tables made by onboard RAID controller. 

Regards!

Comment 5 Martin Vang 2017-07-27 11:25:41 UTC
Thanks Michael for your workaround - worked for me too :)

Comment 6 guazhang@redhat.com 2017-07-28 03:22:56 UTC
it works well for rhel7.4 RC kernel , 

thanks
guazhang

Comment 7 David Lehman 2017-08-03 15:25:10 UTC
Issues like this are usually caused by some preexisting data on the drives, but I cannot tell what the specifics are because no logs were attached and beaker links are not working for me.

If anyone sees this problem and can attach the logs I will be happy to take a look.

Comment 8 Cobra Koral 2017-08-08 16:22:18 UTC
I have the same problem, and I am willing to provide more data as instructed to solve this problem, because I was not able to solve it.
I have a macbook late 2009 with a 500 GB hard drive. I want to dual boot it, and I want to boot RHEL with EFI, definitely, no bios/MBR, so my drive os formatted with GPT partition table format. I have a 200MB EFI FAT partition, and a 50GB HFS+ partition to host macOS. I need to have an physical volume and use the first 200MB EFI partition as /boot since macOS doesn't use it anyway(it writes all of the boot configuration on its internal firmware memory, which partition it will boot, and the kernel is on the mac / partition) so my plan makes totally sense. All of my partitions will be on logical volumes, and I like this I plan to have as few partitions as possible, and use the flexibility of LVM to support my needs on linux.

So, I have tried many times, many different configurations, I just can't wipe the 50GB HFS+ partition because I need to have macOS on this macbook, for eventual needs, the rest I wiped even the macOS recovery partition. My GPT is not hybrid. I was wondering if I was really being able to boot the RHEL 7 installation disc on EFI mode. I have a RHEL 7.3 DVD and  I downloaded the most recent RHEL 7.4 and dd the iso image to a usb disk, and both have the same issue.

The bug always happens on the "INSTALLATION DESTINATION" screen. I tried many different configurations, on my setup, this is totally broken. After many trial an error, I found out that just entering the "INSTALLATION DESTINATION" screen, and not selecting or changing anything, does trigger the problem:

"An unknown error has occurred

This program has encountered an unknown error. You may
report the bug below or quit the program."


I used the report bug button and went all the way through it.
I think all the files got attached.
They are in http://api.access.redhat.com/rs/cases/01907229

Please reopen the bug ask for more information if needed.

Thanks in advance.

Comment 9 vlovejoy 2017-10-06 12:53:50 UTC
Just adding my occurrence of the above issue on my D30. 

I had the above error  on rhel 7.4 iso.
Tried  rhel 6.7 iso and got  "contains BIOS RAID metadata" and "Ignoring disk" message.
Tried removing and creating partions  with fdisk did not work for me. 
Then used dmraid -r -E /dev/sd<x>  to remove the metadata.

Now installing rhel 7.4 is working.

Comment 10 liuzdcq 2018-03-06 10:20:39 UTC
dmraid -r -E /dev/sd<x> 

works for me, thanks @vlovejoy!

first boot in rescue mode then run the command