This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 144253

Summary: Griffin Powermate does not work, not allocated event device
Product: [Fedora] Fedora Reporter: Andy Piper <andy.piper>
Component: udevAssignee: Dave Jones <davej>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: pfrields, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-27 05:52:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Andy Piper 2005-01-05 07:28:09 EST
Description of problem:
The Griffin Powermate does not work in FC3 (tested with kernels
2.6.9-1.681_FC3, 2.6.9-1.724_FC3, 2.6.10-1.727_FC3)

It should be allocated a device node under /dev/input but according to
the kernel messages it is allocated a NULL device.

Jan  4 12:29:09 castor kernel: usb 1-6.3: new low speed USB device
using address 14
Jan  4 12:29:09 castor kernel: usbhid: probe of 1-6.3:1.0 failed with
error -5
Jan  4 12:29:09 castor hal.hotplug[1469]: DEVPATH is not set
Jan  4 12:29:09 castor kernel: input: Griffin PowerMate on <NULL>

Steps to Reproduce:
1. Plug in Griffin Powermate

Actual Results:
1. Not detected correctly by the kernel.

Expected Results:
1. Allocated dev node and available for configuration in X etc. using
something like evrouter.

This worked in FC1 / kernel 2.4.x
Comment 1 Andy Piper 2005-01-05 07:35:33 EST
I tried the fix in #91677 but no effect, log messages exactly as
before. I also note that the evdev module does not appear to be
present on my system, but evdev.h is under /lib/modules/`uname
-r`/build/include/config/input/evdev.h so I assume it is compiled into
the kernel.

Comment 2 Andy Piper 2005-01-06 14:17:35 EST
I wonder if this is something to do with udev or hotplug?
I notice that /dev/input/event2 is touched whenever I plugin the
device, but the log message always indicates <NULL> device allocated.
Comment 3 Andy Piper 2005-01-07 02:10:34 EST
I'm not sure whether I am on the right track here as I've never really
had to do kernel debugging before.

I believe the -5 is -EIO being returned from powermate_probe in
drivers/usb/input/powermate.c
Unfortunately there are 3 conditions on which this might be returned
and at this point the code gets beyond my level of understanding so I
am not sure which is the case.

It is also not clear to me whether the -5 error is anything to do with
the reason that the <NULL> device is allocated when the PowerMate is
plugged in.
Comment 4 Andy Piper 2005-01-07 02:16:56 EST
OK more information on this bug...

Running the userspace tools from 
http://www.graflex.org/klotz/software/griffin/ things now "kind of" work.

The rotomatic utility (reads rotation events) works as my normal user.
The brighten and pulseled utilities fail and report that I don't have
permission to open /dev/input/event2 (it works as root). They are
looking for write access so this makes some sense.

I will try configuring the device for use with the Gimp later.
Comment 5 Andy Piper 2005-01-28 05:12:34 EST
OK I have now found an excellent resource allowing me to get the
PowerMate working in Linux:
http://gentoo-wiki.com/HOWTO_Griffin_PowerMate_with_UDEV_and_Kernel_2.6.x

This details some udev and hotplug changes which need to be made to
set the permissions correctly (so I'm switching this from a kernel to
a udev bug for now).

However it does not resolve the existing problem where the kernel
reports a <NULL> event device has been allocated.
Comment 6 Harald Hoyer 2005-04-27 05:52:52 EDT
no bug in my opinion.. this is a normal user configuration. And no, I will not
start to build up a product database... sry, this does not belong in the
standard udev-package. Everything (but /etc/security/console.perms) could be
packed in config files together in a seperate rpm (PowerMate-0.1.noarch.rpm)