Bug 1442802

Summary: [Backport] spdy fixes to 3.1
Product: OpenShift Container Platform Reporter: Ryan Howe <rhowe>
Component: NodeAssignee: Seth Jennings <sjenning>
Status: CLOSED ERRATA QA Contact: DeShuai Ma <dma>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.1.1CC: aos-bugs, bleanhar, byount, eparis, erich, jokerman, mmccomas, smunilla, wmeng
Target Milestone: ---   
Target Release: 3.1.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
A library used in OCP 3.1 contained an issue where some connections did not terminate cleanly. This issue lead to high memory usage. This fix properly terminates the connections, allowing the memory associated with the connection to be freed as expected.
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-18 09:28:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ryan Howe 2017-04-17 15:06:53 UTC
Description of problem:

Needing backport for PR to OCP 3.1 to fix some issues with OCP nodes having very high memory usage running the OpenShift process. 

https://github.com/openshift/ose/pull/666

Comment 13 errata-xmlrpc 2017-05-18 09:28:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1235