Bug 1443575

Summary: python-ec2-api-tests is missing a dependency on python-botocore
Product: Red Hat OpenStack Reporter: Luigi Toscano <ltoscano>
Component: openstack-ec2-apiAssignee: Chandan Kumar <chkumar>
Status: CLOSED ERRATA QA Contact: awaugama
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 11.0 (Ocata)CC: apevec, chkumar, lhh, matyoung, slinaber
Target Milestone: rc   
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-ec2-api-4.0.0-2.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 20:22:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Luigi Toscano 2017-04-19 13:40:51 UTC
Description of problem:
Deploy OpenStack with director/TripleO, install Tempest (by installing openstack-tempest-all, but remove python-octaria-tests right now which fails for another bug). Configure Tempest with discover-tempest-config. 

Try to run 
$ testr list-tests
The operation fails with:

 Failed to import test module: ec2api.tests.functional.scenario.test_vpn ... ImportError: No module named botocore.exceptions

python-ec2-api-tests is missing a dependency on python-botocore; when the latter is installed, the operation is successful.

This is a packaging problem, easily fixed in the spec file; not a code problem. It potentially impacts the testing and the usage of tempest by the users.

Version-Release number of selected component (if applicable):
python-ec2-api-tests-4.0.0-1.el7ost.noarch
python-tempest-15.0.0-2.el7ost.noarch
python-tempestconf-1.1.0-1.el7ost.noarch

Comment 4 errata-xmlrpc 2017-05-17 20:22:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245