Bug 1447162

Summary: New package: python-paunch
Product: [Community] RDO Reporter: Steve Baker <sbaker>
Component: Package ReviewAssignee: Haïkel Guémar <karlthered>
Status: CLOSED NEXTRELEASE QA Contact: hguemar
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: trunkCC: amoralej, apevec, hguemar, jpena, karlthered, sbaker, therve, tvignaud, zbitter
Target Milestone: ---Flags: karlthered: rdo-review+
Target Release: trunk   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1414051 Environment:
Last Closed: 2017-06-02 13:22:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1427510, 1447127    

Description Steve Baker 2017-05-02 01:00:17 UTC
Proposed spec: TODO

paunch forklifts the logic of the openstack-heat-agents docker-cmd hook into its own library/tool.

The spec file will be proposed once the first paunch-1.0.0 release is complete

Comment 2 Steve Baker 2017-05-03 23:59:52 UTC
Here is the spec, feel free to leave review comments in the github commit

https://github.com/steveb/paunch-distgit/commits/master

Comment 3 Javier Peña 2017-05-04 14:19:35 UTC
Initial licensecheck output:

$ licensecheck -r .
./.coveragerc: *No copyright* UNKNOWN
./.gitreview: *No copyright* UNKNOWN
./.mailmap: *No copyright* UNKNOWN
./.testr.conf: *No copyright* UNKNOWN
./CONTRIBUTING.rst: *No copyright* UNKNOWN
./HACKING.rst: *No copyright* UNKNOWN
./LICENSE: *No copyright* Apache (v2.0)
./MANIFEST.in: *No copyright* UNKNOWN
./README.rst: *No copyright* UNKNOWN
./babel.cfg: *No copyright* UNKNOWN
./requirements.txt: *No copyright* UNKNOWN
./setup.cfg: *No copyright* Apache
./setup.py: Apache (v2.0) GENERATED FILE
./test-requirements.txt: *No copyright* UNKNOWN
./tox.ini: *No copyright* UNKNOWN
./examples/hello-world.yml: *No copyright* UNKNOWN
./paunch/__init__.py: *No copyright* Apache (v2.0)
./paunch/cmd.py: *No copyright* Apache (v2.0)
./paunch/main.py: *No copyright* Apache (v2.0)
./paunch/runner.py: *No copyright* Apache (v2.0)
./doc/source/conf.py: *No copyright* Apache (v2.0)
./doc/source/contributing.rst: *No copyright* UNKNOWN
./doc/source/index.rst: *No copyright* UNKNOWN
./doc/source/installation.rst: *No copyright* UNKNOWN
./doc/source/readme.rst: *No copyright* UNKNOWN
./doc/source/usage.rst: *No copyright* UNKNOWN
./paunch/builder/compose1.py: *No copyright* Apache (v2.0)
./paunch/tests/base.py: Apache (v2.0)
./paunch/tests/test_builder_compose1.py: *No copyright* Apache (v2.0)
./paunch/tests/test_paunch.py: *No copyright* Apache (v2.0)
./paunch/tests/test_runner.py: *No copyright* Apache (v2.0)
./releasenotes/source/conf.py: *No copyright* Apache (v2.0) GENERATED FILE
./releasenotes/source/index.rst: *No copyright* UNKNOWN
./releasenotes/source/unreleased.rst: *No copyright* UNKNOWN

The project is licensed using the Apache 2.0 license. It was created initially using cookiecutter.

Comment 4 Zane Bitter 2017-05-04 14:40:53 UTC
Spec looks OK to me. Any reason it's not python3? I think ideally on Fedora this would use system_python, although AFAIK that's not available on RHEL/CentOS yet.

Comment 5 Alan Pevec 2017-05-12 19:19:30 UTC
(In reply to Zane Bitter from comment #4)
> Spec looks OK to me. Any reason it's not python3? I think ideally on Fedora
> this would use system_python, although AFAIK that's not available on
> RHEL/CentOS yet.

This is RDO Package Review so EL7 / python2 only.

Comment 6 Steve Baker 2017-05-29 19:17:07 UTC
This review has become more urgent, as the heat-agents docker-cmd hook now depends on it https://review.rdoproject.org/r/#/c/6861/1

Comment 7 Javier Peña 2017-05-30 09:45:26 UTC
Could you open a review in review.rdoproject.org with the initial spec? It is step 3 from https://www.rdoproject.org/documentation/rdo-packaging/#how-to-add-a-new-package-to-rdo-trunk

Comment 8 Steve Baker 2017-05-30 20:17:11 UTC
Done https://review.rdoproject.org/r/#/c/6896/

Comment 9 Haïkel Guémar 2017-06-01 23:21:23 UTC
Approved based on latest revision from https://review.rdoproject.org/r/#/c/6896/




Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Package installs properly.
  Note: Installation errors (see attachment)
  See: https://fedoraproject.org/wiki/Packaging:Guidelines
=> False positive


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Apache (v2.0)", "*No copyright* Apache", "Unknown or
     generated", "*No copyright* Apache (v2.0)". 30 files have unknown
     license. Detailed output of licensecheck in /home/hguemar/dist-git-
     delorean/centos-master/data/python-paunch_distro/review-python-
     paunch/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[ ]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in python-
     paunch-doc , python-paunch-tests
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
[x]: Spec file according to URL is the same as in SRPM.


Installation errors
-------------------
INFO: mock.py version 1.4.1 starting (python version = 3.6.1)...
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: run
Start: chroot init
INFO: calling preinit hooks
INFO: enabled HW Info plugin
Mock Version: 1.4.1
INFO: Mock Version: 1.4.1
Finish: chroot init
Start: chroot init
INFO: calling preinit hooks
INFO: enabled HW Info plugin
Mock Version: 1.4.1
INFO: Mock Version: 1.4.1
Finish: chroot init
INFO: installing package(s): /home/hguemar/dist-git-delorean/centos-master/data/python-paunch_distro/review-python-paunch/results/python-paunch-doc-1.1.0-1.el7.noarch.rpm /home/hguemar/dist-git-delorean/centos-master/data/python-paunch_distro/review-python-paunch/results/python-paunch-1.1.0-1.el7.noarch.rpm /home/hguemar/dist-git-delorean/centos-master/data/python-paunch_distro/review-python-paunch/results/python-paunch-tests-1.1.0-1.el7.noarch.rpm
ERROR: Command failed: 
 # /usr/bin/systemd-nspawn -q -M c46cae07fd2f4697b9ae1f5027585193 -D /var/lib/mock/cloud7-openstack-ocata-el7-build-bootstrap/root -a --setenv=TERM=vt100 --setenv=SHELL=/bin/bash --setenv=HOME=/builddir --setenv=HOSTNAME=mock --setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin --setenv=PROMPT_COMMAND=printf "\033]0;<mock-chroot>\007" --setenv=PS1=<mock-chroot> \s-\v\$  --setenv=LANG=en_US.utf8 --setenv=LC_MESSAGES=C /usr/bin/yum --installroot /var/lib/mock/cloud7-openstack-ocata-el7-build/root/ install /home/hguemar/dist-git-delorean/centos-master/data/python-paunch_distro/review-python-paunch/results/python-paunch-doc-1.1.0-1.el7.noarch.rpm /home/hguemar/dist-git-delorean/centos-master/data/python-paunch_distro/review-python-paunch/results/python-paunch-1.1.0-1.el7.noarch.rpm /home/hguemar/dist-git-delorean/centos-master/data/python-paunch_distro/review-python-paunch/results/python-paunch-tests-1.1.0-1.el7.noarch.rpm



Rpmlint
-------
Checking: python-paunch-1.1.0-1.el7.noarch.rpm
          python-paunch-doc-1.1.0-1.el7.noarch.rpm
          python-paunch-tests-1.1.0-1.el7.noarch.rpm
          python-paunch-1.1.0-1.el7.src.rpm
python-paunch.noarch: E: summary-too-long C Library and utility to launch and manage containers using YAML based configuration data
python-paunch.noarch: E: description-line-too-long C Library and utility to launch and manage containers using YAML based configuration data.
python-paunch.noarch: W: no-manual-page-for-binary paunch
python-paunch-doc.noarch: E: description-line-too-long C Library and utility to launch and manage containers using YAML based configuration data.
python-paunch-tests.noarch: E: description-line-too-long C Library and utility to launch and manage containers using YAML based configuration data.
python-paunch-tests.noarch: W: no-documentation
python-paunch.src: E: summary-too-long C Library and utility to launch and manage containers using YAML based configuration data
python-paunch.src: E: description-line-too-long C Library and utility to launch and manage containers using YAML based configuration data.
4 packages and 0 specfiles checked; 6 errors, 2 warnings.




Requires
--------
python-paunch (rpmlib, GLIBC filtered):
    /usr/bin/python2
    docker-common
    python(abi)
    python-cliff
    python-pbr

python-paunch-tests (rpmlib, GLIBC filtered):
    python(abi)
    python-mock
    python-oslotest
    python-paunch
    python-testrepository
    python-testscenarios

python-paunch-doc (rpmlib, GLIBC filtered):



Provides
--------
python-paunch:
    python-paunch

python-paunch-tests:
    python-paunch-tests

python-paunch-doc:
    python-paunch-doc



Source checksums
----------------
https://tarballs.openstack.org/paunch/paunch-1.1.0.tar.gz :
  CHECKSUM(SHA256) this package     : 3b5746228d65b696588b7dae71bdd2ddf40e3b5f2705e19d6a80b471e7b1c2e2
  CHECKSUM(SHA256) upstream package : 3b5746228d65b696588b7dae71bdd2ddf40e3b5f2705e19d6a80b471e7b1c2e2


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -n python-paunch -m rdo-ocata-el7
Buildroot used: cloud7-openstack-ocata-el7-build
Active plugins: Python, Generic, Shell-api
Disabled plugins: Java, C/C++, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 10 Haïkel Guémar 2017-06-02 13:22:26 UTC
Built and imported in trunk