Bug 1447202

Summary: Win 2016 guest is described as Win 10 after imported to RHEVM
Product: Red Hat Enterprise Linux 7 Reporter: kuwei <kuwei>
Component: libguestfsAssignee: Richard W.M. Jones <rjones>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 7.4CC: juzhou, kuwei, mxie, mzhan, ptoscano, rjones, tzheng, vfeenstr, xiaodwan
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: V2V
Fixed In Version: libguestfs-1.36.3-4.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-01 22:13:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
screenshot1
none
v2v.log none

Description kuwei@redhat.com 2017-05-02 06:19:54 UTC
Created attachment 1275566 [details]
screenshot1

Description of problem:
Win 2016 guest is described as Win 10 after imported to RHV

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.9.0-2.el7.x86_64
libvirt-3.2.0-3.el7.x86_64
virt-v2v-1.36.3-3.el7.x86_64
libguestfs-1.36.3-3.el7.x86_64
libguestfs-winsupport-7.2-2.el7.x86_64
RHV Version:4.1.1.2-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1.Convert win2016 guest from local to RHV, conversion log pls refer to attachment
# virt-v2v win2016 -o rhv -os 10.73.131.93:/home/nfs_export
[   0.0] Opening the source -i libvirt win2016
[   0.0] Creating an overlay to protect the source from being modified
[   0.4] Initializing the target -o rhv -os 10.73.131.93:/home/nfs_export
[   1.0] Opening the overlay
[  36.6] Inspecting the overlay
[  39.2] Checking for sufficient free disk space in the guest
[  39.2] Estimating space required on target for each disk
[  39.2] Converting Windows Server 2016 Standard to run on KVM
virt-v2v: warning: /usr/share/virt-tools/pnp_wait.exe is missing.  
Firstboot scripts may conflict with PnP.
virt-v2v: warning: there is no QXL driver for this version of Windows (10.0 
x86_64).  virt-v2v looks for this driver in /usr/share/virtio-win

The guest will be configured to use a basic VGA display driver.
virt-v2v: This guest has virtio drivers installed.
[  43.8] Mapping filesystem data to avoid copying unused and blank areas
[  45.4] Closing the overlay
[  47.4] Checking if the guest needs BIOS or UEFI to boot
[  47.4] Assigning disks to buses
[  47.4] Copying disk 1/1 to /tmp/v2v.uFc9uu/4f699f1d-7f77-4e73-a0d2-a3b73c1a0c29/images/47d64173-da14-4599-9fe9-6a1883d5db2d/af8f009d-9d26-4318-b8b3-72ec27818e74 (qcow2)
    (100.00/100%)
[ 154.6] Creating output metadata
[ 154.8] Finishing off


2.After conversion,import guest from export domain to data domain.

3.Check Operating System of win2016 guest in general info, it shows "Windows 10", please refer to screenshot1


Actual results:
As above description

Expected results:
The general info :Operating System should be Windows 2016 

Additional info:
As windows 2016 has released we can modify the code about description system version about windows 2106

Comment 2 kuwei@redhat.com 2017-05-02 06:21:03 UTC
Created attachment 1275567 [details]
v2v.log

Comment 3 Richard W.M. Jones 2017-05-02 09:55:53 UTC
oVirt has added an OS type for Windows2K16:

https://github.com/oVirt/ovirt-engine/commit/d233325d7b808e8bae83645ac645dfea9dfe8407

so we should support this in virt-v2v.  Should be an easy
patch so I'll look at this in a moment.

Comment 4 Richard W.M. Jones 2017-05-02 10:00:52 UTC
Fixed upstream:

https://github.com/libguestfs/libguestfs/commit/d0344f3522c116d3ccba6d52cd100562ee6e1e23

I guess this is too late for RHEL 7.4.

Comment 5 Richard W.M. Jones 2017-05-02 10:01:21 UTC
(In reply to Richard W.M. Jones from comment #4)
> I guess this is too late for RHEL 7.4.

Although maybe not.  It was PM-acked automatically.

Comment 7 mxie@redhat.com 2017-05-31 10:31:40 UTC
Verify the bug with below builds:
virt-v2v-1.36.3-4.el7.x86_64
libguestfs-1.36.3-4.el7.x86_64
libvirt-3.2.0-6.el7.x86_64
qemu-kvm-1.5.3-139.el7.x86_64
virtio-win-1.9.0-3.el7.noarch

Steps:
1.Convert win2016 guest from vmware to rhv by virt-v2v
# virt-v2v -ic vpx://root@10.73.75.182/data/10.73.72.61/?no_verify=1 esx6.0-win2016-x86_64 -b ovirtmgmt -n ovirtmgmt -o rhv -os 10.73.131.93:/home/nfs_export --password-file /tmp/passwd
[   0.0] Opening the source -i libvirt -ic vpx://root@10.73.75.182/data/10.73.72.61/?no_verify=1 esx6.0-win2016-x86_64
[   1.1] Creating an overlay to protect the source from being modified
[   1.6] Initializing the target -o rhv -os 10.73.131.93:/home/nfs_export
[   1.9] Opening the overlay
[  36.2] Inspecting the overlay
[ 248.0] Checking for sufficient free disk space in the guest
[ 248.0] Estimating space required on target for each disk
[ 248.0] Converting Windows Server 2016 Standard to run on KVM
virt-v2v: warning: /usr/share/virt-tools/pnp_wait.exe is missing.  
Firstboot scripts may conflict with PnP.
virt-v2v: warning: there is no QXL driver for this version of Windows (10.0 
x86_64).  virt-v2v looks for this driver in /usr/share/virtio-win

The guest will be configured to use a basic VGA display driver.
virt-v2v: This guest has virtio drivers installed.
[ 291.9] Mapping filesystem data to avoid copying unused and blank areas
[ 308.2] Closing the overlay
[ 308.6] Checking if the guest needs BIOS or UEFI to boot
[ 308.6] Assigning disks to buses
[ 308.6] Copying disk 1/1 to /tmp/v2v.yrcQJj/4f699f1d-7f77-4e73-a0d2-a3b73c1a0c29/images/92ac9ae3-65ff-4db0-8886-abd39d6bc5b6/cf2305a8-47e1-4c47-9b80-f52ee189bd66 (raw)
    (100.00/100%)
[2430.4] Creating output metadata
[2430.5] Finishing off


2.After finishing conversion,import guest from export domain to data domain at rhv

3.Check Operating System of win2016 guest in general info, it shows " Windows 2016 x64"

4.Power on the guest and checkpoints are passed


According to above test result, move the bug from ON_QA to VERIFIED

Comment 8 errata-xmlrpc 2017-08-01 22:13:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023