Bug 1447276

Summary: curl (77) problem to get https kickstart on nightly test f26-20170430.n.0 at install
Product: [Fedora] Fedora Reporter: Menanteau Guy <menantea>
Component: dracutAssignee: dracut-maint-list
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 26CC: dracut-maint-list, jonathan, normand, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-04 08:31:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1071880, 1430829    

Description Menanteau Guy 2017-05-02 09:51:40 UTC
When using inst.ks=https//.....kickstart.ks on linux boot command to install nightly f26 from 20170430, I get a curl problem in dracut and the installation failed.

[   14.978841] dracut-initqueue[597]:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
[   14.979847] dracut-initqueue[597]:                                  Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
[   15.139411] dracut-initqueue[597]: curl: (77) Problem with the SSL CA cert (path? access rights?)
[   15.140469] dracut-initqueue[597]: Warning: failed to fetch kickstart from https://jskladan.fedorapeople.org/kickstarts/root-user-crypted-net.ks

Notes: 
Getting the kickstart using http is working fine.
When I do not use a kickstart, if I switch to anaconda console at the time I am asked to choose between text and vnc installation, then a curl on https is working fine.

Same tests on Fedora-26-20170429.n.0 works fine and it seems anaconda and dracut  have not changed since.

Comment 1 Menanteau Guy 2017-05-04 08:31:17 UTC

*** This bug has been marked as a duplicate of bug 1447777 ***