Bug 1447734 (CVE-2017-7487)

Summary: CVE-2017-7487 kernel: Reference counter leak in ipxitf_ioctl resulting into use after free
Product: [Other] Security Response Reporter: Adam Mariš <amaris>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: agordeev, aquini, bhu, dhoward, esammons, fhrbata, iboverma, jkacur, jross, lgoncalv, lwang, matt, mcressma, mguzik, nmurray, pholasek, plougher, rvrbovsk, security-response-team, vdronov, williams
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
A reference counter leak in Linux kernel in ipxitf_ioctl function was found which results in a use after free vulnerability that's triggerable from unprivileged userspace when IPX interface is configured.
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-12 13:28:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1450417    
Bug Blocks: 1447735    

Description Adam Mariš 2017-05-03 15:33:43 UTC
A reference counter leak in ipxitf_ioctl function was found which results into use after free vulnerability that's triggerable from unprivileged userspace when IPX interface is configured.

References:

http://seclists.org/oss-sec/2017/q2/251

https://patchwork.ozlabs.org/patch/757549/

Upstream patch:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ee0d8d8482345ff97a75a7d747efc309f13b0d80

Comment 1 Adam Mariš 2017-05-03 15:33:55 UTC
Acknowledgments:

Name: Li Qiang (Qihoo 360)

Comment 4 Vladis Dronov 2017-05-12 13:20:25 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 1450417]

Comment 6 Eric Christensen 2017-05-16 12:29:42 UTC
Statement:

This issue does not affect the versions of the Linux kernel as shipped with Red Hat Enterprise Linux 5, 6, 7 and Red Hat Enterprise MRG 2 as the code with the flaw is not shipped with the products listed.