Description of problem: "admin" username can't be used. But we are able to create such request wich will fail with :
[[Azure::Armrest::BadRequestException]: The Admin Username specified is not allowed.] Message [[Azure::Armrest::BadRequestException]: The Admin Username specified is not allowed.]
Version-Release number of selected component (if applicable):5.8.0.16
How reproducible:100%
Steps to Reproduce:
1.use "admin" username during Instance provision on azure provider
2.
3.
Actual results: Request gets created but fails
Expected results: Warning message in UI
Yes, there is a list of usernames that are not allowed by Azure. Why? Not sure, must be some attempt at security. In any case, I'll add some hooks to catch those.